aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
Commit message (Collapse)AuthorAgeFilesLines
* boinc: refresh patchesstagging/master-next2Armin Kuster2018-05-201-5/+7
| | | | | | used quilt refresh patch Signed-off-by: Armin Kuster <akuster808@gmail.com>
* lvm2: refresh patchesArmin Kuster2018-05-205-88/+73
| | | | | | used quilt to refresh Signed-off-by: Armin Kuster <akuster808@gmail.com>
* iperf3: Drop redundant patchKhem Raj2018-05-182-26/+0
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* lmbench: fix Upstream-Status metadata typos in patchMikko Rapeli2018-05-181-1/+1
| | | | | Signed-off-by: Mikko Rapeli <mikko.rapeli@bmw.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* rocksdb: update to 5.13.1Pascal Bach2018-05-182-198/+3
| | | | | Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libmicrohttpd: update to version 0.9.59Richard Leitner2018-05-181-2/+2
| | | | | Signed-off-by: Richard Leitner <richard.leitner@skidata.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* gtest: switch away from github archiveTrevor Woerner2018-05-181-6/+3
| | | | | | | | | | Since we know that github archives which are automatically generated have a tendency to change their checksums[1], switch to using a git clone. [1] http://lists.openembedded.org/pipermail/openembedded-devel/2017-September/114916.html Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* minicoredumper: relocate admin-binaries to sbinChristophe PRIOUZEAU2018-05-181-0/+4
| | | | | | | | | | | | Change path of minicoredumper on init/service script to /usr/sbin. Since the commit "relocate admin-binaries to sbin" on minicoredumper, minicoredumper binaries are installed on /usr/sbin directory instead of /usr/bin. src/minicoredumper/Makefile.am: sbin_PROGRAMS = minicoredumper Signed-off-by: Christophe Priouzeau <christophe.priouzeau@st.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* xorgxrdp: Fix the LicenseZheng Ruoqin2018-05-181-1/+1
| | | | | | | Change the License to MIT as Fedora. And I also found the license it's MIT in the spdx file of xorgxrdp. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* Fix zram module paramter nameMichael Siebecker2018-05-181-1/+1
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* scancode.bbclass: Adding a bbclass for scancode license scaning utilityirfan sadiq2018-05-181-0/+35
| | | | | | | | | | | | | | | This is adding the functionality to run scancode utility on code. You need to set the following variables to use it. You can override these from local.conf or auto.conf. 1) SCANCODE_GIT_LOCATION: Git Path for scancode-toolkit cloning, default is set. 2) SCANCODE_TAG: Select tag, if you want. 3) SCANCODE_FORMAT: Output file format json or html-app. 4) SCANCODE_SRC_LOCATION: Location to store scancode-toolkit. This belongs to OI-2. Signed-off-by: H M Irfan Sadiq <irfan_sadiq@mentor.com> Signed-off-by: Noor Ahsan <noor_ahsan@mentor.com>
* libvdpau: Rename dep dri2proto -> xorgprotoKhem Raj2018-05-181-1/+1
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* xtscal: RemoveKhem Raj2018-05-185-712/+0
| | | | | | | Remove dead X11 proto and library packages OE-Core droppped libxcalibrate which it needed Signed-off-by: Khem Raj <raj.khem@gmail.com>
* nbench-byte: Dont append cflags to ccKhem Raj2018-05-181-1/+1
| | | | | | adding cflags is redundant Signed-off-by: Khem Raj <raj.khem@gmail.com>
* minicoredumper: fixes for sysvinit and systemdtexierp2018-05-182-2/+2
| | | | | | | | | The sysv initscript and systemd service assumes minicoredumper is installed in /usr/bin/. In our case minicoredumper is installed in /usr/sbin/ by default. Therefore, fix this path. Signed-off-by: Pierre-Jean TEXIER <texier.pj2@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* openwsman: 2.6.3 -> 2.6.4Hong Liu2018-05-181-2/+2
| | | | | | | Upgrade openwsman from 2.6.3 to 2.6.4 Signed-off-by: Hong Liu <hongl.fnst@cn.fujitsu.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* collectd: Upgrade to 5.8.0Khem Raj2018-05-185-84/+135
| | | | | | | | Fix build with gcc8 along the way Forward port existing patches Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* mosquito: move from oe to networking layerArmin Kuster2018-05-185-1197/+0
| | | | | | mosquito has dependancy on meta-netowrking packages Signed-off-by: Armin Kuster <akuster808@gmail.com>
* grpc: move it from oe to networking layerArmin Kuster2018-05-184-312/+0
| | | | | | grpc has dependancy on meta-networking packages. Signed-off-by: Armin Kuster <akuster808@gmail.com>
* poco: update to 1.9.0Pascal Bach2018-05-171-25/+17
| | | | | | | | | | Enable the new Encodings and Redis packages by default. Splitting into sub packages now uses PACKAGES_DYNAMIC instead of the custom logic used before. Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* stm32flash: add recipeRichard Leitner2018-05-171-0/+16
| | | | | | | | Add recipe for version 0.5 of stm32flash, an open source flash program for STM32 using the ST serial bootloader. Signed-off-by: Richard Leitner <richard.leitner@skidata.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* lvm2: 2.02.171 -> 2.02.277Hong Liu2018-05-172-4/+4
| | | | | | | Upgrade lvm2 from 2.02.171 to 2.02.277. Signed-off-by: Hong Liu <hongl.fnst@cn.fujitsu.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* htop: Fix typoRobert Joslyn2018-05-171-1/+1
| | | | | Signed-off-by: Robert Joslyn <robert.joslyn@redrectangle.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* python-cpuset: switch away from github archiveTrevor Woerner2018-05-171-8/+3
| | | | | | | | | | Since we know that github archives which are automatically generated have a tendency to change their checksums[1], switch to using a git clone. [1] http://lists.openembedded.org/pipermail/openembedded-devel/2017-September/114916.html Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* libwebsockets: update 2.1.0 -> 3.0.0Trevor Woerner2018-05-171-2/+2
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | The LICENSE checksum update was required because the LICENSE file added an initial clause, and the locations of the third-party sources changed. Here is a diff of the old and new licenses: --- LICENSE.old 2018-05-11 14:36:05.053031281 -0400 +++ LICENSE.new 2018-05-11 14:35:40.364931066 -0400 @@ -1,7 +1,13 @@ Libwebsockets and included programs are provided under the terms of the GNU Library General Public License (LGPL) 2.1, with the following exceptions: -1) Static linking of programs with the libwebsockets library does not +1) Any reference, whether in these modifications or in the GNU +Library General Public License 2.1, to this License, these terms, the +GNU Lesser Public License, GNU Library General Public License, LGPL, or +any similar reference shall refer to the GNU Library General Public +License 2.1 as modified by these paragraphs 1) through 4). + +2) Static linking of programs with the libwebsockets library does not constitute a derivative work and does not require the author to provide source code for the program, use the shared libwebsockets libraries, or link their program against a user-supplied version of libwebsockets. @@ -10,7 +16,7 @@ changes to libwebsockets must be provided under the terms of the LGPL in sections 1, 2, and 4. -2) You do not have to provide a copy of the libwebsockets license with +3) You do not have to provide a copy of the libwebsockets license with programs that are linked to the libwebsockets library, nor do you have to identify the libwebsockets license in your program or documentation as required by section 6 of the LGPL. @@ -22,26 +28,30 @@ "[program] is based in part on the work of the libwebsockets project (https://libwebsockets.org)" -3) Some sources included have their own, more liberal licenses, or options +4) Some sources included have their own, more liberal licenses, or options to get original sources with the liberal terms. Original liberal license retained - - lib/sha-1.c - 3-clause BSD license retained, link to original + - lib/misc/sha-1.c - 3-clause BSD license retained, link to original - win32port/zlib - ZLIB license (see zlib.h) + - lib/tls/mbedtls/wrapper - Apache 2.0 (only built if linked against mbedtls) Relicensed to libwebsocket license - - lib/base64-decode.c - relicensed to LGPL2.1+SLE, link to original - - lib/daemonize.c - relicensed from Public Domain to LGPL2.1+SLE, - link to original Public Domain version + - lib/misc/base64-decode.c - relicensed to LGPL2.1+SLE, link to original + - lib/misc/daemonize.c - relicensed from Public Domain to LGPL2.1+SLE, + link to original Public Domain version Public Domain (CC-zero) to simplify reuse - - test-server/*.c - - test-server/*.h + - test-apps/*.c + - test-apps/*.h + - minimal-examples/* - lwsws/* - + +------ end of exceptions + GNU LESSER GENERAL PUBLIC LICENSE Version 2.1, February 1999 Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* libwebsockets: switch away from github archiveTrevor Woerner2018-05-171-4/+3
| | | | | | | | | | Since we know that github archives which are automatically generated have a tendency to change their checksums[1], switch to using a git clone. [1] http://lists.openembedded.org/pipermail/openembedded-devel/2017-September/114916.html Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* rocksdb: Fix build with gcc8Khem Raj2018-05-172-1/+197
| | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* luajit: Dont use BUILD_LDFLAGS when compiling host binariesKhem Raj2018-05-171-5/+4
| | | | | | | | | | | | | | | | | | | BUILD_LDFLAGS add --dynamic-linker to point to uninative but some binaries in luajit are for 32bit build host, so even if your host has the needed runtime, it will fail to execute because uninative ldso doesn't know about multilib we get cyptic errors like | make[1]: execvp: host/minilua: Accessing a corrupted shared library | make[1]: *** [Makefile:610: host/buildvm_arch.h] Error 127 Switch to using git for SRC_URI, master is pointing to latest 2.0 stable, it gets us all the patches done since last 2.0.5 relases in 2017 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* flashrom: Fix build with libusb 1.0.22Khem Raj2018-05-172-0/+40
| | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* libopus: add native and nativesdkMartin Jansa2018-05-171-0/+2
| | | | | | | * can be used by spice Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* libuv: update 1.11.0 -> 1.20.3Trevor Woerner2018-05-171-2/+2
| | | | | | | | | | | | | | | | | | | | | | | | The license change is as a result of removing one of the files (pthread-fixes.h) from the list of files from Google and Sony. No change in license has occurred. Here is a diff of the license file: --- LICENSE.old 2018-05-11 10:50:19.024581228 -0400 +++ LICENSE.new 2018-05-11 10:49:53.088488515 -0400 @@ -62,8 +62,8 @@ - stdint-msvc2008.h (from msinttypes), copyright Alexander Chemeris. Three clause BSD license. - - pthread-fixes.h, pthread-fixes.c, copyright Google Inc. and Sony Mobile - Communications AB. Three clause BSD license. + - pthread-fixes.c, copyright Google Inc. and Sony Mobile Communications AB. + Three clause BSD license. - android-ifaddrs.h, android-ifaddrs.c, copyright Berkeley Software Design Inc, Kenneth MacKay and Emergya (Cloud4all, FP7/2007-2013, grant agreement Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* libuv: switch away from github archiveTrevor Woerner2018-05-171-4/+4
| | | | | | | | | | Since we know that github archives which are automatically generated have a tendency to change their checksums[1], switch to using a git clone. [1] http://lists.openembedded.org/pipermail/openembedded-devel/2017-September/114916.html Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* poppler: Update to 0.64Khem Raj2018-05-172-8/+39
| | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* upm: Fix build with gcc8Khem Raj2018-05-172-1/+51
| | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* openocd: Upgrade to tip of masterKhem Raj2018-05-176-298/+1
| | | | | | | Drop upstreamed patches Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* lmbench: Link with libtirpc on glibc as wellKhem Raj2018-05-171-3/+3
| | | | | | | glibc has dropped obsoleted rpc support Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* postgresql: Depend on external libnslKhem Raj2018-05-172-6/+1
| | | | | | | glibc has dropped libnsl support Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* poppler-data: Upgrade to 0.4.9Khem Raj2018-05-171-2/+2
| | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* modemmanager: fix mbim disable stringMartin Kelly2018-05-171-1/+1
| | | | | | | | The current string used to disable mbim is "--enable-mbim=no", which is producing a warning. It should be "--with-mdim=no", so change it. Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* modemmanager: upgrade to 1.7.991Martin Kelly2018-05-172-26/+4
| | | | | | | | | This version has a ublox plugin for expanded modem support. The underlying issue that enum-conversion.patch fixes appears to already have been fixed upstream, so we can drop the patch. Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* xorg: Replace depreciated *proto depends with xorgprotoRobert Yang2018-05-172-3/+3
| | | | | | | | The oe-core commit 9d236bd40ef8598c78c1ea807d658467700505e2 has removed *proto, we also need to do so in meta-openembedded. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* xproto -> xorgproto fixupTrevor Woerner2018-05-173-3/+3
| | | | | | | | | In openembedded-core, commit 460a2b27af8d023b27703b491331c8cbe7aad0ff deprectated xproto and xextproto for xorgproto due to changes in the upstream Xorg project. Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* libmbim: Upgrade to 1.16.0Khem Raj2018-05-171-2/+2
| | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* geany-plugins: Add dependency on fribidiKhem Raj2018-05-171-0/+1
| | | | | | | | | | | | | Its needed by addons Fixes ld: cannot find -lfribidi | collect2: error: ld returned 1 exit status | make[3]: *** [Makefile:569: addons.la] Error 1 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* openobex: explicitly set ASNEEDED from openobex recipeAndre McCurdy2018-05-171-0/+2
| | | | | | | | | | | Up to now, an openobex specific over-ride for ASNEEDED has been provided by oe-core (from as-needed.inc). If ASNEEDED does need to be over-ridden in order to build openobex it's not ideal that the over-ride comes from a different layer so define it directly in the meta-oe recipe. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* krb5: support environment setting on systemdHongxu Jia2018-05-174-3/+8
| | | | | | | | | | | | | | | | | | Let krb5 support environment setting on systemd startup. Here is one requirement of environment setting from upstream krb5 ... https://web.mit.edu/kerberos/krb5-1.16/doc/admin/conf_files/kdc_conf.html |Normally, the kdc.conf file is found in the KDC state directory, LOCALSTATEDIR/krb5kdc. You can override the default location by setting the environment variable KRB5_KDC_PROFILE. ... The fix of (krb5-admin-server.service/krb5-kdc.service) refers ubuntu 1604 Variable RUN_KADMIND is sysvinit, move it out from default/krb5-admin-server Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* phoronix-test-suite: disable systemd services by defaultSlater, Joseph2018-05-171-0/+5
| | | | | | | | | | Unfortunately, the default behavior for at least the client service is to reboot the machine if it encounters problems. Since it is pretty much guaranteed to need target specific configuration info, we should not enable the service(s) by default. Signed-off-by: Joe Slater <joe.slater@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* libyui: Fix build with clangKhem Raj2018-05-012-0/+688
| | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* p7zip: Fix build with clangKhem Raj2018-05-012-2/+52
| | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* ceres-solver: Upgrade to 1.14Khem Raj2018-05-011-1/+1
| | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>