aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain-layer/recipes-devtools/gcc/gcc-4.5/Makefile.in.patch
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain-layer/recipes-devtools/gcc/gcc-4.5/Makefile.in.patch')
-rw-r--r--toolchain-layer/recipes-devtools/gcc/gcc-4.5/Makefile.in.patch30
1 files changed, 0 insertions, 30 deletions
diff --git a/toolchain-layer/recipes-devtools/gcc/gcc-4.5/Makefile.in.patch b/toolchain-layer/recipes-devtools/gcc/gcc-4.5/Makefile.in.patch
deleted file mode 100644
index 45df47c5bf..0000000000
--- a/toolchain-layer/recipes-devtools/gcc/gcc-4.5/Makefile.in.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Index: gcc-4.5/gcc/Makefile.in
-===================================================================
---- gcc-4.5.orig/gcc/Makefile.in
-+++ gcc-4.5/gcc/Makefile.in
-@@ -656,7 +656,7 @@ LIBGCC2_INCLUDES =
- TARGET_LIBGCC2_CFLAGS =
-
- # Options to use when compiling crtbegin/end.
--CRTSTUFF_CFLAGS = -O2 $(GCC_CFLAGS) $(INCLUDES) $(MULTILIB_CFLAGS) -g0 \
-+CRTSTUFF_CFLAGS = -O2 $(GCC_CFLAGS) $(TARGET_INCLUDES) $(MULTILIB_CFLAGS) -g0 \
- -finhibit-size-directive -fno-inline -fno-exceptions \
- -fno-zero-initialized-in-bss -fno-toplevel-reorder -fno-tree-vectorize \
- $(INHIBIT_LIBC_CFLAGS)
-@@ -1038,10 +1038,14 @@ BUILD_ERRORS = build/errors.o
- # -I$(@D) and -I$(srcdir)/$(@D) cause the subdirectory of the file
- # currently being compiled, in both source trees, to be examined as well.
- # libintl.h will be found in ../intl if we are using the included libintl.
--INCLUDES = -I. -I$(@D) -I$(srcdir) -I$(srcdir)/$(@D) \
-+#
-+# TARGET_INCLUDES is added to avoid that GMPINC (which points to the host
-+# include dir) is used for compiling libgcc.a
-+TARGET_INCLUDES = -I. -I$(@D) -I$(srcdir) -I$(srcdir)/$(@D) \
- -I$(srcdir)/../include @INCINTL@ \
-- $(CPPINC) $(GMPINC) $(DECNUMINC) \
-+ $(CPPINC) $(DECNUMINC) \
- $(PPLINC) $(CLOOGINC) $(LIBELFINC)
-+INCLUDES = $(TARGET_INCLUDES) $(GMPINC)
-
- .c.o:
- $(COMPILER) -c $(ALL_COMPILERFLAGS) $(ALL_CPPFLAGS) $< $(OUTPUT_OPTION)