aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain-layer/recipes-core/eglibc/eglibc_2.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain-layer/recipes-core/eglibc/eglibc_2.12.bb')
-rw-r--r--toolchain-layer/recipes-core/eglibc/eglibc_2.12.bb109
1 files changed, 0 insertions, 109 deletions
diff --git a/toolchain-layer/recipes-core/eglibc/eglibc_2.12.bb b/toolchain-layer/recipes-core/eglibc/eglibc_2.12.bb
deleted file mode 100644
index 3509e8daa8..0000000000
--- a/toolchain-layer/recipes-core/eglibc/eglibc_2.12.bb
+++ /dev/null
@@ -1,109 +0,0 @@
-require recipes-core/eglibc/eglibc.inc
-
-DEPENDS += "gperf-native"
-PR = "r28"
-
-SRCREV = "15872"
-
-EGLIBC_BRANCH="eglibc-2_12"
-SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http \
- file://eglibc-svn-arm-lowlevellock-include-tls.patch \
- file://IO-acquire-lock-fix.patch \
- file://shorten-build-commands.patch \
- file://mips-rld-map-check.patch \
- file://armv4-eabi-compile-fix.patch \
- file://ppc-enable-603e-cpu.patch \
- file://etc/ld.so.conf \
- file://generate-supported.mk \
- "
-SRC_URI_append_virtclass-nativesdk = " file://ld-search-order.patch"
-S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
-B = "${WORKDIR}/build-${TARGET_SYS}"
-
-PACKAGES_DYNAMIC = "libc6*"
-RPROVIDES_${PN}-dev = "libc6-dev virtual-libc-dev"
-PROVIDES_${PN}-dbg = "glibc-dbg"
-
-# the -isystem in bitbake.conf screws up glibc do_stage
-BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
-TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${layout_includedir}"
-
-GLIBC_ADDONS ?= "ports,nptl,libidn"
-
-GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN es_CR.ISO-8859-1"
-
-FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/eglibc-${PV}', '${FILE_DIRNAME}/eglibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
-
-#
-# For now, we will skip building of a gcc package if it is a uclibc one
-# and our build is not a uclibc one, and we skip a glibc one if our build
-# is a uclibc build.
-#
-# See the note in gcc/gcc_3.4.0.oe
-#
-
-python __anonymous () {
- import bb, re
- uc_os = (re.match('.*uclibc$', bb.data.getVar('TARGET_OS', d, 1)) != None)
- if uc_os:
- raise bb.parse.SkipPackage("incompatible with target %s" %
- bb.data.getVar('TARGET_OS', d, 1))
-}
-
-export libc_cv_slibdir = "${base_libdir}"
-
-EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
- --without-cvs --disable-profile --disable-debug --without-gd \
- --enable-clocale=gnu \
- --enable-add-ons=${GLIBC_ADDONS},ports \
- --with-headers=${STAGING_INCDIR} \
- --without-selinux \
- ${GLIBC_EXTRA_OECONF}"
-
-EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
-
-do_unpack_append() {
- bb.build.exec_func('do_move_ports', d)
-}
-
-do_move_ports() {
- if test -d ${WORKDIR}/${EGLIBC_BRANCH}/ports ; then
- rm -rf ${S}/ports
- mv ${WORKDIR}/${EGLIBC_BRANCH}/ports ${S}/
- fi
-}
-
-do_configure () {
-# override this function to avoid the autoconf/automake/aclocal/autoheader
-# calls for now
-# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
-# version check and doesn't really help with anything
- if [ -z "`which rpcgen`" ]; then
- echo "rpcgen not found. Install glibc-devel."
- exit 1
- fi
- (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
- find ${S} -name "configure" | xargs touch
- CPPFLAGS="" oe_runconf
-}
-
-rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
- yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
- rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
-
-do_compile () {
- # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
- unset LDFLAGS
- base_do_compile
- (
- cd ${S}/sunrpc/rpcsvc
- for r in ${rpcsvc}; do
- h=`echo $r|sed -e's,\.x$,.h,'`
- rpcgen -h $r -o $h || bbwarn "unable to generate header for $r"
- done
- )
-}
-
-require recipes-core/eglibc/eglibc-package.inc
-
-BBCLASSEXTEND = "nativesdk"