aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.0.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.0.bb b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.0.bb
index 9ac99a8b7e..d41f9ca051 100644
--- a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.0.bb
+++ b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.0.bb
@@ -2,13 +2,15 @@ SUMMARY = "Xfce4 Panel"
SECTION = "x11"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=26a8bd75d8f8498bdbbe64a27791d4ee"
-DEPENDS = "libxfce4util garcon libxfce4ui xfconf exo gtk+ dbus cairo virtual/libx11 libxml2 libwnck"
+DEPENDS = "libxfce4util garcon libxfce4ui xfconf exo gtk+ gtk+3 dbus cairo virtual/libx11 libxml2 libwnck"
inherit xfce gtk-doc
SRC_URI[md5sum] = "5a333af704e386c90ad829b6baf1a758"
SRC_URI[sha256sum] = "30920fc2e2fc26279a82b5261a155c2cc15ab2aa1ced2275684a6ff8261b97b0"
+EXTRA_OECONF += "--enable-gtk3"
+
python populate_packages_prepend() {
plugin_dir = d.expand('${libdir}/xfce4/panel/plugins/')
plugin_name = d.expand('${PN}-plugin-%s')
@@ -22,8 +24,14 @@ python populate_packages_prepend() {
PACKAGES_DYNAMIC += "^${PN}-plugin-.*"
+PACKAGES =+ "${PN}-gtk3"
+
FILES_${PN} += "${libdir}/xfce4/panel/migrate \
${libdir}/xfce4/panel/wrapper-1.0"
+FILES_${PN}-gtk3 = " \
+ ${libdir}/libxfce4panel-2.0${SOLIBS} \
+ ${libdir}/xfce4/panel/wrapper-2.0 \
+"
FILES_${PN}-dbg += "${libdir}/xfce4/panel/plugins/.debug \
"