aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/packagegroups
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-xfce/packagegroups')
-rw-r--r--meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-base.bb6
-rw-r--r--meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-extended.bb11
2 files changed, 9 insertions, 8 deletions
diff --git a/meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-base.bb b/meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-base.bb
index 70ef909ef9..c4b7b34cec 100644
--- a/meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-base.bb
+++ b/meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-base.bb
@@ -1,12 +1,14 @@
SUMMARY = "All packages required for a base installation of XFCE"
SECTION = "x11/wm"
-PR = "r5"
+
+# librsvg-gtk gets debian renamed to librsvg-2-gtk
+PACKAGE_ARCH = "${TUNE_PKGARCH}"
inherit packagegroup features_check
REQUIRED_DISTRO_FEATURES = "x11"
-RDEPENDS_${PN} = " \
+RDEPENDS:${PN} = " \
xfwm4 \
xfce4-session \
xfconf \
diff --git a/meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-extended.bb b/meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-extended.bb
index 7f1c172616..f2e04f7932 100644
--- a/meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-extended.bb
+++ b/meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-extended.bb
@@ -1,19 +1,18 @@
SUMMARY = "All packages for full XFCE installation"
SECTION = "x11/wm"
-PR = "r10"
inherit packagegroup features_check
REQUIRED_DISTRO_FEATURES = "x11"
# mandatory
-RDEPENDS_${PN} = " \
+RDEPENDS:${PN} = " \
packagegroup-xfce-base \
"
# nice to have
-RRECOMMENDS_${PN} = " \
+RRECOMMENDS:${PN} = " \
xfwm4-theme-daloa \
xfwm4-theme-kokodi \
xfwm4-theme-moheli \
@@ -50,7 +49,7 @@ RRECOMMENDS_${PN} = " \
xfce4-verve-plugin \
\
${@bb.utils.contains('DISTRO_FEATURES','polkit','xfce-polkit','',d)} \
- ${@bb.utils.contains("DISTRO_FEATURES", "bluetooth", "blueman", "", d)} \
+ ${@bb.utils.contains("DISTRO_FEATURES", "bluetooth gobject-introspection", "blueman", "", d)} \
\
thunar-media-tags-plugin \
thunar-archive-plugin \
@@ -63,6 +62,6 @@ RRECOMMENDS_${PN} = " \
xfce4-taskmanager \
gigolo \
mousepad \
- catfish \
- xfce4-panel-profiles \
+ ${@bb.utils.contains("DISTRO_FEATURES", "gobject-introspection-data", "catfish", "", d)} \
+ ${@bb.utils.contains("DISTRO_FEATURES", "gobject-introspection-data", "xfce4-panel-profiles", "", d)} \
"