aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/garcon/garcon_0.8.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-xfce/garcon/garcon_0.8.0.bb')
-rw-r--r--meta-xfce/recipes-xfce/garcon/garcon_0.8.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/garcon/garcon_0.8.0.bb b/meta-xfce/recipes-xfce/garcon/garcon_0.8.0.bb
new file mode 100644
index 0000000000..bbaa6fd6f7
--- /dev/null
+++ b/meta-xfce/recipes-xfce/garcon/garcon_0.8.0.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Xfce Menu Library"
+SECTION = "x11/libs"
+LICENSE = "LGPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=04a01abcbdabffae1ca26335a293276b"
+DEPENDS = "xfce4-dev-tools-native libxfce4ui intltool-native"
+
+inherit xfce gtk-doc gobject-introspection features_check
+
+REQUIRED_DISTRO_FEATURES = "x11"
+
+SRC_URI += "file://0001-xfce-applications.menu-don-t-bloat-settings-menu-by-.patch"
+SRC_URI[sha256sum] = "4811d89ee5bc48dbdeffd69fc3eec6c112bbf01fde98a9e848335b374a4aa1bb"
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+do_compile_prepend() {
+ export GIR_EXTRA_LIBS_PATH="${B}/garcon/.libs"
+}
+
+FILES_${PN} += "${datadir}/desktop-directories"