aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb b/meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb
index e34fba2607..3aaa5c2d4d 100644
--- a/meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb
+++ b/meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb
@@ -18,7 +18,7 @@ TARGET_CC_ARCH += "${LDFLAGS}"
DEPENDS = "openssl"
-inherit update-rc.d
+inherit update-rc.d useradd
INITSCRIPT_NAME = "nostromo"
INITSCRIPT_PARAMS = "defaults 70"
@@ -27,6 +27,11 @@ do_compile() {
oe_runmake
}
+# we need user/group www-data to exist when we install
+#
+USERADD_PACKAGES = "${PN}"
+USERADD_PARAM_${PN} = "--system -g www-data www-data"
+
do_install() {
install -d ${D}/${sbindir}
install -m 0755 src/nhttpd/nhttpd ${D}/${sbindir}/nhttpd