aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-httpd/nostromo/files/0001-GNUmakefile-add-possibility-to-override-variables.patch14
-rw-r--r--meta-webserver/recipes-httpd/nostromo/nostromo_1.9.6.bb (renamed from meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb)6
2 files changed, 12 insertions, 8 deletions
diff --git a/meta-webserver/recipes-httpd/nostromo/files/0001-GNUmakefile-add-possibility-to-override-variables.patch b/meta-webserver/recipes-httpd/nostromo/files/0001-GNUmakefile-add-possibility-to-override-variables.patch
index 7cf011b1c8..8cd4682355 100644
--- a/meta-webserver/recipes-httpd/nostromo/files/0001-GNUmakefile-add-possibility-to-override-variables.patch
+++ b/meta-webserver/recipes-httpd/nostromo/files/0001-GNUmakefile-add-possibility-to-override-variables.patch
@@ -91,7 +91,9 @@ diff --git a/src/nhttpd/GNUmakefile b/src/nhttpd/GNUmakefile
index f6d12de..9524911 100644
--- a/src/nhttpd/GNUmakefile
+++ b/src/nhttpd/GNUmakefile
-@@ -1,18 +1,18 @@
+@@ -1,20 +1,20 @@
+ # $nostromo: GNUmakefile,v 1.6 2016/04/12 19:02:06 hacki Exp $
+
-CCFLAGS = -O2 -pipe -Wall -Wstrict-prototypes -c
+CFLAGS := -O2 -pipe -Wall -Wstrict-prototypes -c
@@ -120,14 +122,16 @@ diff --git a/src/tools/GNUmakefile b/src/tools/GNUmakefile
index 15bea61..663ddb5 100644
--- a/src/tools/GNUmakefile
+++ b/src/tools/GNUmakefile
-@@ -1,11 +1,11 @@
+@@ -1,13 +1,13 @@
+ # $nostromo: GNUmakefile,v 1.3 2016/04/12 19:02:58 hacki Exp $
+
-CCFLAGS = -O2 -pipe -Wall -Werror -Wstrict-prototypes -c
-+CCFLAGS := -O2 -pipe -Wall -Werror -Wstrict-prototypes
++CFLAGS = -O2 -pipe -Wall -Werror -Wstrict-prototypes
crypt: crypt.o
-- cc -o crypt crypt.o -lcrypt
+- cc -L../libbsd -o crypt crypt.o -lcrypt -lbsd
- strip crypt
-+ $(CC) $(CFLAGS) -o crypt crypt.o -lcrypt
++ $(CC) $(CFLAGS) -L../libbsd -o crypt crypt.o -lcrypt -lbsd
+# $(STRIP) crypt
crypt.o: crypt.c
diff --git a/meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb b/meta-webserver/recipes-httpd/nostromo/nostromo_1.9.6.bb
index 562ecd0049..e06a6965fc 100644
--- a/meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb
+++ b/meta-webserver/recipes-httpd/nostromo/nostromo_1.9.6.bb
@@ -1,7 +1,7 @@
SUMMARY = "A simple, fast and secure HTTP server"
HOMEPAGE = "http://www.nazgul.ch/dev_nostromo.html"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://src/nhttpd/main.c;beginline=2;endline=14;md5=e5ec3fa723b29b7d59d205afd8d36938"
+LIC_FILES_CHKSUM = "file://src/nhttpd/main.c;beginline=2;endline=14;md5=0bb3711a867b9704d3bfabcf5529b64e"
SRC_URI = "http://www.nazgul.ch/dev/${BPN}-${PV}.tar.gz \
file://0001-GNUmakefile-add-possibility-to-override-variables.patch \
@@ -11,8 +11,8 @@ SRC_URI = "http://www.nazgul.ch/dev/${BPN}-${PV}.tar.gz \
file://nostromo \
"
-SRC_URI[md5sum] = "dc6cfd6b5aae04c370c7f818fa7bde55"
-SRC_URI[sha256sum] = "5f62578285e02449406b46cf06a7888fe3dc4a90bedf58cc18523bad62f6b914"
+SRC_URI[md5sum] = "27aa241d78ff78920354c3e03a5026ea"
+SRC_URI[sha256sum] = "541494ecfeafec58c0876ccc90cc23b06e0144f6f42029af44c7cdb1f411e8eb"
TARGET_CC_ARCH += "${LDFLAGS}"