aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2/apache-configure_perlbin.patch12
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2/apache-ssl-ltmain-rpath.patch23
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2/replace-lynx-to-curl-in-apachectl-script.patch17
3 files changed, 24 insertions, 28 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2/apache-configure_perlbin.patch b/meta-webserver/recipes-httpd/apache2/apache2/apache-configure_perlbin.patch
index c90279d449..92c53f31d7 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2/apache-configure_perlbin.patch
+++ b/meta-webserver/recipes-httpd/apache2/apache2/apache-configure_perlbin.patch
@@ -4,11 +4,13 @@
#
# Upstream-Status: Inappropriate [configuration]
---- a/configure.in
-+++ b/configure.in
-@@ -638,10 +638,7 @@
- AC_DEFINE_UNQUOTED(APACHE_MPM_DIR, "$MPM_DIR",
- [Location of the source for the current MPM])
+Index: httpd-2.4.29/configure.in
+===================================================================
+--- httpd-2.4.29.orig/configure.in
++++ httpd-2.4.29/configure.in
+@@ -855,10 +855,7 @@ AC_DEFINE_UNQUOTED(SERVER_CONFIG_FILE, "
+ AC_DEFINE_UNQUOTED(AP_TYPES_CONFIG_FILE, "${rel_sysconfdir}/mime.types",
+ [Location of the MIME types config file, relative to the Apache root directory])
-perlbin=`$ac_aux_dir/PrintPath perl`
-if test "x$perlbin" = "x"; then
diff --git a/meta-webserver/recipes-httpd/apache2/apache2/apache-ssl-ltmain-rpath.patch b/meta-webserver/recipes-httpd/apache2/apache2/apache-ssl-ltmain-rpath.patch
index 413dc535e4..f13da91f39 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2/apache-ssl-ltmain-rpath.patch
+++ b/meta-webserver/recipes-httpd/apache2/apache2/apache-ssl-ltmain-rpath.patch
@@ -1,11 +1,11 @@
build/ltmain.sh | 32 +++++++++++++++++++++++++++-----
1 file changed, 27 insertions(+), 5 deletions(-)
-diff --git a/build/ltmain.sh b/build/ltmain.sh
-index 5eca4ae..805b461 100644
---- a/build/ltmain.sh
-+++ b/build/ltmain.sh
-@@ -6944,7 +6944,7 @@ func_mode_link ()
+Index: httpd-2.4.29/build/ltmain.sh
+===================================================================
+--- httpd-2.4.29.orig/build/ltmain.sh
++++ httpd-2.4.29/build/ltmain.sh
+@@ -6969,7 +6969,7 @@ func_mode_link ()
dir=$func_resolve_sysroot_result
# We need an absolute path.
case $dir in
@@ -14,7 +14,7 @@ index 5eca4ae..805b461 100644
*)
absdir=`cd "$dir" && pwd`
test -z "$absdir" && \
-@@ -8137,7 +8137,7 @@ func_mode_link ()
+@@ -8167,7 +8167,7 @@ func_mode_link ()
$ECHO "*** $linklib is not portable!"
fi
if test lib = "$linkmode" &&
@@ -23,7 +23,7 @@ index 5eca4ae..805b461 100644
# Hardcode the library path.
# Skip directories that are in the system default run-time
# search path.
-@@ -8404,7 +8404,7 @@ func_mode_link ()
+@@ -8434,7 +8434,7 @@ func_mode_link ()
if test lib = "$linkmode"; then
if test -n "$dependency_libs" &&
@@ -32,7 +32,7 @@ index 5eca4ae..805b461 100644
test yes = "$build_old_libs" ||
test yes = "$link_static"; }; then
# Extract -R from dependency_libs
-@@ -9025,7 +9025,8 @@ func_mode_link ()
+@@ -9086,7 +9086,8 @@ func_mode_link ()
*) func_append finalize_rpath " $libdir" ;;
esac
done
@@ -42,7 +42,7 @@ index 5eca4ae..805b461 100644
dependency_libs="$temp_xrpath $dependency_libs"
fi
fi
-@@ -9473,7 +9474,7 @@ EOF
+@@ -9534,7 +9535,7 @@ EOF
case $archive_cmds in
*\$LD\ *) wl= ;;
esac
@@ -51,7 +51,7 @@ index 5eca4ae..805b461 100644
# Hardcode the library paths
hardcode_libdirs=
dep_rpath=
-@@ -10211,6 +10212,27 @@ EOF
+@@ -10272,6 +10273,27 @@ EOF
# Now hardcode the library paths
rpath=
hardcode_libdirs=
@@ -79,6 +79,3 @@ index 5eca4ae..805b461 100644
for libdir in $compile_rpath $finalize_rpath; do
if test -n "$hardcode_libdir_flag_spec"; then
if test -n "$hardcode_libdir_separator"; then
---
-1.9.1
-
diff --git a/meta-webserver/recipes-httpd/apache2/apache2/replace-lynx-to-curl-in-apachectl-script.patch b/meta-webserver/recipes-httpd/apache2/apache2/replace-lynx-to-curl-in-apachectl-script.patch
index 584ddc8d94..e4e01b2af6 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2/replace-lynx-to-curl-in-apachectl-script.patch
+++ b/meta-webserver/recipes-httpd/apache2/apache2/replace-lynx-to-curl-in-apachectl-script.patch
@@ -10,11 +10,11 @@ Signed-off-by: Yulong Pei <Yulong.pei@windriver.com>
support/apachectl.in | 14 ++++++++++----
1 files changed, 10 insertions(+), 4 deletions(-)
-diff --git a/support/apachectl.in b/support/apachectl.in
-index d4dff38..109ea13 100644
---- a/support/apachectl.in
-+++ b/support/apachectl.in
-@@ -51,11 +51,11 @@ fi
+Index: httpd-2.4.29/support/apachectl.in
+===================================================================
+--- httpd-2.4.29.orig/support/apachectl.in
++++ httpd-2.4.29/support/apachectl.in
+@@ -52,11 +52,11 @@ fi
# a command that outputs a formatted text version of the HTML at the
# url given on the command line. Designed for lynx, however other
# programs may work.
@@ -28,7 +28,7 @@ index d4dff38..109ea13 100644
#
# Set this variable to a command that increases the maximum
# number of file descriptors allowed per child process. This is
-@@ -91,10 +91,16 @@ configtest)
+@@ -92,10 +92,16 @@ configtest)
ERROR=$?
;;
status)
@@ -46,7 +46,4 @@ index d4dff38..109ea13 100644
+ fi
;;
*)
- $HTTPD $ARGV
---
-1.6.4
-
+ $HTTPD "$@"