aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend')
-rw-r--r--meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend b/meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend
new file mode 100644
index 0000000000..06993025f1
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend
@@ -0,0 +1,23 @@
+inherit systemd
+
+PRINC := "${@int(PRINC) + 2}"
+
+# look for files in the layer first
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://busybox-syslog.service.in \
+ file://busybox-klogd.service.in"
+
+SYSTEMD_PACKAGES = "${PN}-syslog"
+SYSTEMD_SERVICE_${PN}-syslog = "busybox-syslog.service"
+
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system
+ sed 's,@base_sbindir@,${base_sbindir},g' < ${WORKDIR}/busybox-syslog.service.in \
+ > ${D}${systemd_unitdir}/system/busybox-syslog.service
+ sed 's,@base_sbindir@,${base_sbindir},g' < ${WORKDIR}/busybox-klogd.service.in \
+ > ${D}${systemd_unitdir}/system/busybox-klogd.service
+
+ ln -sf /dev/null ${D}${systemd_unitdir}/system/syslog.service
+}
+FILES_${PN}-syslog += "${systemd_unitdir}/system/syslog.service"