aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.2p1.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.2p1.bbappend')
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.2p1.bbappend21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.2p1.bbappend b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.2p1.bbappend
new file mode 100644
index 0000000000..4789ad06fe
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.2p1.bbappend
@@ -0,0 +1,21 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+PRINC := "${@int(PRINC) + 3}"
+
+SYSTEMD_PACKAGES = "${PN}-sshd"
+SYSTEMD_SERVICE_${PN}-sshd = "sshd.socket"
+FILES_${PN}-sshd += "${systemd_unitdir}/system/sshd.socket"
+RPROVIDES_${PN}-sshd += "${PN}-sshd-systemd"
+RREPLACES_${PN}-sshd += "${PN}-sshd-systemd"
+RCONFLICTS_${PN}-sshd += "${PN}-sshd-systemd"
+
+inherit systemd
+
+SRC_URI += "file://sshd.socket file://sshd@.service file://sshdgenkeys.service"
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/sshd.socket ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/sshd@.service ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/sshdgenkeys.service ${D}${systemd_unitdir}/system
+}
+