aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-twisted.inc4
-rw-r--r--meta-python/recipes-devtools/python/python3-twisted_18.4.0.bb2
2 files changed, 2 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python-twisted.inc b/meta-python/recipes-devtools/python/python-twisted.inc
index 01616b168b..456adf4c39 100644
--- a/meta-python/recipes-devtools/python/python-twisted.inc
+++ b/meta-python/recipes-devtools/python/python-twisted.inc
@@ -35,7 +35,6 @@ PACKAGES += "\
"
PACKAGES =+ "\
- ${PN}-src \
${PN}-bin \
"
@@ -242,9 +241,10 @@ FILES_${PN}-doc += " \
${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_pydoctortemplates/ \
"
-RDEPENDS_{PN}-src = "${PN}"
+RDEPENDS_${PN}-src = "${PN}"
FILES_${PN}-src = " \
${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py \
${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*.py \
${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/*.py \
"
+
diff --git a/meta-python/recipes-devtools/python/python3-twisted_18.4.0.bb b/meta-python/recipes-devtools/python/python3-twisted_18.4.0.bb
index 6bd8c52eb0..dfb9d4a4cc 100644
--- a/meta-python/recipes-devtools/python/python3-twisted_18.4.0.bb
+++ b/meta-python/recipes-devtools/python/python3-twisted_18.4.0.bb
@@ -1,8 +1,6 @@
inherit pypi setuptools3
require python-twisted.inc
-PACKAGES_remove = "${PN}-src"
-
FILES_${PN}-core_append += " \
${libdir}/${PYTHON_DIR}/site-packages/twisted/__pycache__ \
${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__pycache__/*pyc \