aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb b/meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb
index 7410749071..a699f1c7e3 100644
--- a/meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb
+++ b/meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb
@@ -1,5 +1,5 @@
require python-pywbem.inc
-inherit setuptools
+inherit setuptools update-alternatives
DEPENDS += " \
${PYTHON_PN}-m2crypto-native \
@@ -11,3 +11,10 @@ RDEPENDS_${PN}_class-target += "\
${PYTHON_PN}-m2crypto \
${PYTHON_PN}-subprocess \
"
+
+ALTERNATIVE_${PN} = "mof_compiler pywbemcli wbemcli"
+ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler"
+ALTERNATIVE_TARGET[pywbemcli] = "${bindir}/pywbemcli"
+ALTERNATIVE_TARGET[wbemcli] = "${bindir}/wbemcli"
+
+ALTERNATIVE_PRIORITY = "30"