aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-packaging.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-packaging_19.2.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-packaging_19.2.bb2
3 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-packaging.inc b/meta-python/recipes-devtools/python/python-packaging.inc
new file mode 100644
index 0000000000..c32caaa408
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-packaging.inc
@@ -0,0 +1,10 @@
+DESCRIPTION = "Core utilities for Python packages"
+HOMEPAGE = "https://github.com/pypa/packaging"
+LICENSE = "Apache-2.0 & BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=faadaedca9251a90b205c9167578ce91"
+
+SRC_URI[md5sum] = "867ce70984dc7b89bbbc3cac2a72b171"
+SRC_URI[sha256sum] = "28b924174df7a2fa32c1953825ff29c61e2f5e082343165438812f00d3a7fc47"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+RDEPENDS_${PN} += "${PYTHON_PN}-six ${PYTHON_PN}-pyparsing"
diff --git a/meta-python/recipes-devtools/python/python-packaging_19.2.bb b/meta-python/recipes-devtools/python/python-packaging_19.2.bb
new file mode 100644
index 0000000000..55d0746bb5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-packaging_19.2.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools
+require python-packaging.inc
diff --git a/meta-python/recipes-devtools/python/python3-packaging_19.2.bb b/meta-python/recipes-devtools/python/python3-packaging_19.2.bb
new file mode 100644
index 0000000000..aa20fb26f9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-packaging_19.2.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools3
+require python-packaging.inc