aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-waitress.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-waitress_1.3.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-waitress_1.3.1.bb2
3 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-waitress.inc b/meta-python/recipes-devtools/python/python-waitress.inc
new file mode 100644
index 0000000000..732c31dbd7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-waitress.inc
@@ -0,0 +1,10 @@
+SUMMARY = "A WSGI server for Python"
+DESCRIPTION = "Waitress is meant to be a production-quality pure-Python WSGI \
+ server with very acceptable performance."
+HOMEPAGE = "https://github.com/Pylons/waitress"
+SECTION = "devel/python"
+LICENSE = "ZPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=78ccb3640dc841e1baecb3e27a6966b2"
+
+SRC_URI[md5sum] = "d9132d313de0c5e0fec34ef9ede5442e"
+SRC_URI[sha256sum] = "278e09d6849acc1365404bbf7d790d0423b159802e850c726e8cd0a126a2dac7"
diff --git a/meta-python/recipes-devtools/python/python-waitress_1.3.1.bb b/meta-python/recipes-devtools/python/python-waitress_1.3.1.bb
new file mode 100644
index 0000000000..26a628ea02
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-waitress_1.3.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools pypi
+require python-waitress.inc
diff --git a/meta-python/recipes-devtools/python/python3-waitress_1.3.1.bb b/meta-python/recipes-devtools/python/python3-waitress_1.3.1.bb
new file mode 100644
index 0000000000..83c8b66d82
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-waitress_1.3.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools3 pypi
+require python-waitress.inc