aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pyserial.inc7
-rw-r--r--meta-python/recipes-devtools/python/python-pyserial_3.3.bb (renamed from meta-python/recipes-devtools/python/python-pyserial_3.2.1.bb)0
-rw-r--r--meta-python/recipes-devtools/python/python3-pyserial_3.3.bb (renamed from meta-python/recipes-devtools/python/python3-pyserial_3.2.1.bb)2
3 files changed, 7 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyserial.inc b/meta-python/recipes-devtools/python/python-pyserial.inc
index c1c1904f1a..2508e76c0d 100644
--- a/meta-python/recipes-devtools/python/python-pyserial.inc
+++ b/meta-python/recipes-devtools/python/python-pyserial.inc
@@ -7,11 +7,14 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=d476d94926db6e0008a5b3860d1f5c0d"
RDEPENDS_${PN} = "\
${PYTHON_PN}-fcntl \
${PYTHON_PN}-io \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-netclient \
${PYTHON_PN}-stringold \
+ ${PYTHON_PN}-threading \
"
-SRC_URI[md5sum] = "7142a421c8b35d2dac6c47c254db023d"
-SRC_URI[sha256sum] = "1eecfe4022240f2eab5af8d414f0504e072ee68377ba63d3b6fe6e66c26f66d1"
+RSRC_URI[md5sum] = "6afe4c2e47bcec6eb7051b8c1ce19d52"
+SRC_URI[sha256sum] = "2949cddffc2b05683065a3cd2345114b1a49b08df8cb843d69ba99dc3e19edc2"
inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-pyserial_3.2.1.bb b/meta-python/recipes-devtools/python/python-pyserial_3.3.bb
index 91a0f26ac3..91a0f26ac3 100644
--- a/meta-python/recipes-devtools/python/python-pyserial_3.2.1.bb
+++ b/meta-python/recipes-devtools/python/python-pyserial_3.3.bb
diff --git a/meta-python/recipes-devtools/python/python3-pyserial_3.2.1.bb b/meta-python/recipes-devtools/python/python3-pyserial_3.3.bb
index 17ed3f8bc4..44c13685e9 100644
--- a/meta-python/recipes-devtools/python/python3-pyserial_3.2.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pyserial_3.3.bb
@@ -5,3 +5,5 @@ do_install_append() {
rm -f ${D}${bindir}/miniterm.py
rmdir ${D}${bindir}
}
+
+RDEPENDS_${PN} += "${PYTHON_PN}-enum ${PYTHON_PN}-selectors"