aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-paho-mqtt.inc14
-rw-r--r--meta-python/recipes-devtools/python/python-paho-mqtt_1.2.bb16
-rw-r--r--meta-python/recipes-devtools/python/python3-paho-mqtt_1.2.bb3
3 files changed, 19 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python-paho-mqtt.inc b/meta-python/recipes-devtools/python/python-paho-mqtt.inc
new file mode 100644
index 0000000000..7ff3fb242f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-paho-mqtt.inc
@@ -0,0 +1,14 @@
+SUMMARY = "MQTT version 3.1/3.1.1 client library"
+LICENSE = "EPL-1.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=eb48c6ee2cb9f5b8b9fe75e6f817bdfc"
+SRCNAME = "paho-mqtt"
+
+inherit pypi
+SRC_URI[md5sum] = "241150b3fcb920ddca4d33181f3238b1"
+SRC_URI[sha256sum] = "9100a6aa706ab699d414ec02705a21eb66f436184691d0bf1f2a85a6213c6c1f"
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-math \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-threading \
+"
diff --git a/meta-python/recipes-devtools/python/python-paho-mqtt_1.2.bb b/meta-python/recipes-devtools/python/python-paho-mqtt_1.2.bb
index c8acfc5579..f369b2e848 100644
--- a/meta-python/recipes-devtools/python/python-paho-mqtt_1.2.bb
+++ b/meta-python/recipes-devtools/python/python-paho-mqtt_1.2.bb
@@ -1,15 +1,3 @@
-SUMMARY = "MQTT version 3.1/3.1.1 client library"
-LICENSE = "EPL-1.0"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=eb48c6ee2cb9f5b8b9fe75e6f817bdfc"
-SRCNAME = "paho-mqtt"
+inherit setuptools
+require python-paho-mqtt.inc
-inherit pypi setuptools
-
-RDEPENDS_${PN} = "\
- python-math \
- python-io \
- python-threading \
-"
-
-SRC_URI[md5sum] = "241150b3fcb920ddca4d33181f3238b1"
-SRC_URI[sha256sum] = "9100a6aa706ab699d414ec02705a21eb66f436184691d0bf1f2a85a6213c6c1f"
diff --git a/meta-python/recipes-devtools/python/python3-paho-mqtt_1.2.bb b/meta-python/recipes-devtools/python/python3-paho-mqtt_1.2.bb
new file mode 100644
index 0000000000..4981e61ed8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-paho-mqtt_1.2.bb
@@ -0,0 +1,3 @@
+inherit setuptools3
+require python-paho-mqtt.inc
+