aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-python/python-pip_1.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-python/python-pip_1.3.1.bb')
-rw-r--r--meta-python/recipes-python/python-pip_1.3.1.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-python/python-pip_1.3.1.bb b/meta-python/recipes-python/python-pip_1.3.1.bb
new file mode 100644
index 0000000000..d1a7c8b3ae
--- /dev/null
+++ b/meta-python/recipes-python/python-pip_1.3.1.bb
@@ -0,0 +1,14 @@
+SUMMARY = "PIP is a tool for installing and managing Python packages"
+LICENSE = "MIT & GPL"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cd00425a3465a0e4c81929b94241d3de"
+
+SRC_URI = "https://pypi.python.org/packages/source/p/pip/pip-${PV}.tar.gz"
+SRC_URI[md5sum] = "cbb27a191cebc58997c4da8513863153"
+SRC_URI[sha256sum] = "145eaa5d1ea1b062663da1f3a97780d7edea4c63c68a37c463b1deedf7bb4957"
+
+S = "${WORKDIR}/pip-${PV}"
+
+inherit setuptools
+
+# Since PIP is like CPAN for PERL we need to drag in all python modules to ensure everything works
+RDEPENDS_${PN} = "python-modules"