aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-python/python-numeric/no-lapack.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-python/python-numeric/no-lapack.patch')
-rw-r--r--meta-python/recipes-python/python-numeric/no-lapack.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-python/recipes-python/python-numeric/no-lapack.patch b/meta-python/recipes-python/python-numeric/no-lapack.patch
new file mode 100644
index 0000000000..c1916b8b9f
--- /dev/null
+++ b/meta-python/recipes-python/python-numeric/no-lapack.patch
@@ -0,0 +1,33 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- Numeric-23.7/setup.py~nolapack
++++ Numeric-23.7/setup.py
+@@ -32,7 +32,7 @@
+ mathlibs = []
+
+ # delete all but the first one in this list if using your own LAPACK/BLAS
+-sourcelist = [os.path.join('Src', 'lapack_litemodule.c'),
++sourcelist = [
+ #os.path.join('Src', 'blas_lite.c'),
+ #os.path.join('Src', 'f2c_lite.c'),
+ #os.path.join('Src', 'zlapack_lite.c'),
+@@ -40,12 +40,12 @@
+ ]
+ # set these to use your own BLAS;
+
+-library_dirs_list = ['/usr/lib/atlas']
+-libraries_list = ['lapack', 'cblas', 'f77blas', 'atlas', 'g2c']
++library_dirs_list = []
++libraries_list = []
+
+ # set to true (1), if you also want BLAS optimized matrixmultiply/dot/innerproduct
+-use_dotblas = 1
+-include_dirs = ['/usr/include/atlas']
++use_dotblas = 0
++include_dirs = []
+ # You may need to set this to find cblas.h
+ # e.g. on UNIX using ATLAS this should be ['/usr/include/atlas']
+ extra_link_args = []