aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-python/python-autobahn_0.8.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-python/python-autobahn_0.8.6.bb')
-rw-r--r--meta-python/recipes-python/python-autobahn_0.8.6.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-python/python-autobahn_0.8.6.bb b/meta-python/recipes-python/python-autobahn_0.8.6.bb
new file mode 100644
index 0000000000..ac775c4c33
--- /dev/null
+++ b/meta-python/recipes-python/python-autobahn_0.8.6.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "AutobahnPython provides a WebSocket (RFC6455, Hybi-10 to -17, Hixie-76) framework for creating WebSocket-based clients and servers. \
+AutobahnPython also includes an implementation of WAMP (The WebSockets Application Messaging Protocol), a light-weight, \
+asynchronous RPC/PubSub over JSON/WebSocket protocol."
+HOMEPAGE = "http://autobahn.ws/python"
+SECTION = "console/network"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = " file://autobahn/__init__.py;beginline=1;endline=17;md5=1fdeccf6e5b70cda64cc1345597c18e3"
+
+SRC_URI = "https://pypi.python.org/packages/source/a/autobahn/autobahn-${PV}.zip"
+SRC_URI[md5sum] = "160429e7fb043940e79aa7f4ebbab57a"
+SRC_URI[sha256sum] = "94ae5c6f37f9fe7c9d3f12c170fcc273afed4104a1c5508b26d6014bb9e6373e"
+
+S = "${WORKDIR}/autobahn-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} = "python python-pprint python-twisted-protocols python-netserver python-twisted-web"
+