aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended/python-cson/python3-cson_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-extended/python-cson/python3-cson_git.bb')
-rw-r--r--meta-python/recipes-extended/python-cson/python3-cson_git.bb13
1 files changed, 9 insertions, 4 deletions
diff --git a/meta-python/recipes-extended/python-cson/python3-cson_git.bb b/meta-python/recipes-extended/python-cson/python3-cson_git.bb
index 5c74c7a307..489733c767 100644
--- a/meta-python/recipes-extended/python-cson/python3-cson_git.bb
+++ b/meta-python/recipes-extended/python-cson/python3-cson_git.bb
@@ -7,15 +7,20 @@ LICENSE = "MIT"
SECTION = "devel/python"
LIC_FILES_CHKSUM = "file://LICENSE;md5=7709d2635e63ab96973055a23c2a4cac"
-SRCREV = "f3f2898c44bb16b951d3e9f2fbf6d1c4158edda2"
-SRC_URI = "git://github.com/gt3389b/python-cson.git"
+PV = "1.0.9+1.0.10"
+SRCREV = "69090778bccc5ed124342ba288597fbb2bfa9f39"
+SRC_URI = "git://github.com/gt3389b/python-cson.git;branch=master;protocol=https \
+ file://0001-setup.py-Do-not-poke-at-git-describe-to-find-version.patch"
S = "${WORKDIR}/git"
-RDEPENDS_${PN}_class-native = ""
-DEPENDS_append_class-native = " python-native "
+RDEPENDS:${PN} = "python3-json"
inherit setuptools3
+do_configure:prepend() {
+ echo "__version__=${PV}" > ${S}/version.py
+}
+
BBCLASSEXTEND = "native"