aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-extended/python-blivet/python3-blivetgui_2.5.0.bb')
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivetgui_2.5.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.5.0.bb b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.5.0.bb
new file mode 100644
index 0000000000..124f36c6e0
--- /dev/null
+++ b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.5.0.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "GUI tool for storage configuration using blivet library"
+HOMEPAGE = "https://github.com/rhinstaller/blivet-gui"
+LICENSE = "GPL-2.0-or-later"
+SECTION = "devel/python"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://github.com/storaged-project/blivet-gui.git;branch=main;protocol=https"
+SRCREV = "626b44610a30ad26734dd20642538caab5a9178a"
+
+S = "${WORKDIR}/git"
+
+inherit features_check setuptools3
+REQUIRED_DISTRO_FEATURES = "x11 systemd gobject-introspection-data"
+
+RDEPENDS:${PN} = "python3-pygobject python3 \
+ python3-blivet gtk+3 \
+ python3-pid libreport \
+"
+
+FILES:${PN} += "${datadir}/*"