aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-extended/python-blivet/python3-blivetgui_2.2.1.bb')
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivetgui_2.2.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.2.1.bb b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.2.1.bb
new file mode 100644
index 0000000000..ad3c0730f7
--- /dev/null
+++ b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.2.1.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "GUI tool for storage configuration using blivet library"
+HOMEPAGE = "https://github.com/rhinstaller/blivet-gui"
+LICENSE = "GPLv2+"
+SECTION = "devel/python"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+S = "${WORKDIR}/git"
+B = "${S}"
+
+SRCREV = "adb6bd69fb3cfa709265db66ddcee04c0b5e070f"
+SRC_URI = "git://github.com/storaged-project/blivet-gui.git"
+
+inherit features_check
+REQUIRED_DISTRO_FEATURES = "x11 systemd"
+
+inherit setuptools3 python3native
+
+RDEPENDS:${PN} = "python3-pygobject python3 \
+ python3-blivet gtk+3 \
+ python3-pid libreport \
+"
+
+FILES:${PN} += " \
+ ${datadir}/* \
+ "