aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-pymysql.inc18
-rw-r--r--meta-python/recipes-devtools/python/python-pymysql_0.9.3.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pymysql_0.9.3.bb2
3 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pymysql.inc b/meta-python/recipes-devtools/python/python-pymysql.inc
new file mode 100644
index 0000000000..8c7f4556cb
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pymysql.inc
@@ -0,0 +1,18 @@
+SUMMARY = "A pure-Python MySQL client library"
+DESCRIPTION = " \
+ This package contains a pure-Python MySQL client library, based on PEP 249 \
+ Most public APIs are compatible with mysqlclient and MySQLdb. \
+ "
+SECTION = "devel/python"
+HOMEPAGE = "https://pymysql.readthedocs.io"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=528175c84163bb800d23ad835c7fa0fc"
+
+SRC_URI[md5sum] = "e5d9183cc0a775ac29f9e0365cca6556"
+SRC_URI[sha256sum] = "d8c059dcd81dedb85a9f034d5e22dcb4442c0b201908bede99e306d65ea7c8e7"
+
+inherit pypi
+
+PYPI_PACKAGE = "PyMySQL"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-cryptography"
diff --git a/meta-python/recipes-devtools/python/python-pymysql_0.9.3.bb b/meta-python/recipes-devtools/python/python-pymysql_0.9.3.bb
new file mode 100644
index 0000000000..27d097ee6b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pymysql_0.9.3.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-pymysql.inc
diff --git a/meta-python/recipes-devtools/python/python3-pymysql_0.9.3.bb b/meta-python/recipes-devtools/python/python3-pymysql_0.9.3.bb
new file mode 100644
index 0000000000..13774bd632
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pymysql_0.9.3.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-pymysql.inc