aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-xlsxwriter_1.4.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-xlsxwriter_1.4.5.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-xlsxwriter_1.4.5.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-xlsxwriter_1.4.5.bb b/meta-python/recipes-devtools/python/python3-xlsxwriter_1.4.5.bb
new file mode 100644
index 0000000000..ffd3072a99
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-xlsxwriter_1.4.5.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Python 2 and 3 compatibility library"
+HOMEPAGE = "https://xlsxwriter.readthedocs.io"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4e95e368cd6cb090815046688e92d11e"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "XlsxWriter"
+
+RDEPENDS:${PN} += " \
+ python3-crypt \
+ python3-datetime \
+ python3-compression \
+ python3-numbers \
+ python3-io \
+"
+
+SRC_URI[sha256sum] = "0956747859567ec01907e561a7d8413de18a7aae36860f979f9da52b9d58bc19"
+
+BBCLASSEXTEND = "native nativesdk"