aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.5.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.5.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.5.bb b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.5.bb
new file mode 100644
index 0000000000..206a9ab3b0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.5.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \
+application developers the full power and flexibility of SQL"
+HOMEPAGE = "http://www.sqlalchemy.org/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3359ed561ac16aaa25b6c6eff84df595"
+
+SRC_URI[sha256sum] = "1294f05916c044631fd626a4866326bbfbd17f62bd37510d000afaef4b35bd74"
+
+PYPI_PACKAGE = "SQLAlchemy"
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-threading \
+"