aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyperclip_1.8.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyperclip_1.8.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyperclip_1.8.1.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyperclip_1.8.1.bb b/meta-python/recipes-devtools/python/python3-pyperclip_1.8.1.bb
new file mode 100644
index 0000000000..211580b37c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyperclip_1.8.1.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "A cross-platform clipboard module for Python. (only handles plain text for now)"
+HOMEPAGE = "https://github.com/asweigart/pyperclip"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=d7dd4b0d1f7153322a546e89b5a0a632"
+
+SRC_URI[md5sum] = "0ac879899da5c2af755a834245ca6a0f"
+SRC_URI[sha256sum] = "9abef1e79ce635eb62309ecae02dfb5a3eb952fa7d6dce09c1aef063f81424d3"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-ctypes \
+"
+
+BBCLASSEXTEND = "native nativesdk"