aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyjwt_2.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyjwt_2.2.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyjwt_2.2.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyjwt_2.2.0.bb b/meta-python/recipes-devtools/python/python3-pyjwt_2.2.0.bb
new file mode 100644
index 0000000000..761d55d8e5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyjwt_2.2.0.bb
@@ -0,0 +1,15 @@
+SUMMARY = "JSON Web Token implementation in Python"
+DESCRIPTION = "A Python implementation of JSON Web Token draft 32.\
+ Original implementation was written by https://github.com/progrium"
+HOMEPAGE = "http://github.com/jpadilla/pyjwt"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=68626705a7b513ca8d5f44a3e200ed0c"
+
+SRC_URI[sha256sum] = "a0b9a3b4e5ca5517cac9f1a6e9cd30bf1aa80be74fcdf4e28eded582ecfcfbae"
+
+PYPI_PACKAGE = "PyJWT"
+inherit pypi setuptools3
+
+RDEPENDS:${PN} = "${PYTHON_PN}-cryptography"
+
+BBCLASSEXTEND = "native nativesdk"