aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-protobuf_3.9.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-protobuf_3.9.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-protobuf_3.9.2.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-protobuf_3.9.2.bb b/meta-python/recipes-devtools/python/python3-protobuf_3.9.2.bb
new file mode 100644
index 0000000000..30ea34e908
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-protobuf_3.9.2.bb
@@ -0,0 +1,10 @@
+inherit setuptools3
+require python-protobuf.inc
+
+DEPENDS += "protobuf"
+DISTUTILS_BUILD_ARGS += "--cpp_implementation"
+DISTUTILS_INSTALL_ARGS += "--cpp_implementation"
+
+do_compile_prepend_class-native () {
+ export KOKORO_BUILD_NUMBER="1"
+}