aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-polyline_1.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-polyline_1.4.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-polyline_1.4.0.bb15
1 files changed, 14 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-polyline_1.4.0.bb b/meta-python/recipes-devtools/python/python3-polyline_1.4.0.bb
index 3b3e2071f1..d81ee5445c 100644
--- a/meta-python/recipes-devtools/python/python3-polyline_1.4.0.bb
+++ b/meta-python/recipes-devtools/python/python3-polyline_1.4.0.bb
@@ -6,8 +6,21 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=0fbd13500cabd06dd751ba6b2be304c6"
SRC_URI[md5sum] = "b97c57378605c4a856c437569f95a0cb"
SRC_URI[sha256sum] = "7c7f89d09a09c7b6161bdbfb4fd304b186fc7a2060fa4f31cb3f61c646a5c074"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
RDEPENDS_${PN} += "python3-six"
BBCLASSEXTEND = "native nativesdk"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/test
+ cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
+}