aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pandas_1.3.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pandas_1.3.5.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pandas_1.3.5.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pandas_1.3.5.bb b/meta-python/recipes-devtools/python/python3-pandas_1.3.5.bb
new file mode 100644
index 0000000000..2547875395
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pandas_1.3.5.bb
@@ -0,0 +1,26 @@
+SUMMARY = "pandas library for high-performance data analysis tools"
+DESCRIPTION = "pandas is an open source, BSD-licensed library providing \
+high-performance, easy-to-use data structures and data analysis tools for \
+the Python programming language."
+HOMEPAGE = "http://pandas.pydata.org/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3f23c5c092b74d245d48eeef72bc3fd2"
+
+SRC_URI[sha256sum] = "1e4285f5de1012de20ca46b188ccf33521bff61ba5c5ebd78b4fb28e5416a9f1"
+
+inherit pypi setuptools3
+
+DEPENDS += " \
+ ${PYTHON_PN}-numpy-native ${PYTHON_PN}-cython-native \
+"
+
+CFLAGS:append:toolchain-clang = " -Wno-error=deprecated-declarations"
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-numpy \
+ ${PYTHON_PN}-dateutil \
+ ${PYTHON_PN}-dateutil-zoneinfo \
+ ${PYTHON_PN}-pytz \
+ ${PYTHON_PN}-profile \
+"