aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-marshmallow_3.15.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-marshmallow_3.15.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-marshmallow_3.15.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-marshmallow_3.15.0.bb b/meta-python/recipes-devtools/python/python3-marshmallow_3.15.0.bb
new file mode 100644
index 0000000000..c8e0fa4dd3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-marshmallow_3.15.0.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Simplified object serialization in python"
+DESCRIPTION = "Marshmallow is an ORM/ODM/framework-agnostic library for converting complex datatypes, such as objects, to and from native Python datatypes."
+AUTHOR = "Marius Kriegerowski <mk@quakesaver.net>"
+HOMEPAGE = "https://github.com/marshmallow-code/marshmallow"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "\
+ file://LICENSE;md5=5bccd400dedfa74364481e56aacc0b4a \
+ file://docs/license.rst;md5=13da439ad060419fb7cf364523017cfb"
+
+SRC_URI = "git://github.com/marshmallow-code/marshmallow.git;protocol=https;branch=dev"
+
+SRCREV = "f251dfb08d79c755c2e95371f2c5580bf5937e60"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+PIP_INSTALL_PACKAGE = "marshmallow"
+
+RDEPENDS:${PN} += " \
+ python3-core \
+ python3-datetime \
+ python3-netclient \
+ python3-numbers \
+ python3-json \
+ python3-pprint \
+ python3-packaging \
+"