aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-isort_5.9.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-isort_5.9.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-isort_5.9.3.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-isort_5.9.3.bb b/meta-python/recipes-devtools/python/python3-isort_5.9.3.bb
new file mode 100644
index 0000000000..44a51db28f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-isort_5.9.3.bb
@@ -0,0 +1,20 @@
+SUMMARY = "A Python utility / library to sort Python imports."
+HOMEPAGE = "https://pypi.python.org/pypi/isort"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=6;endline=6;md5=8227180126797a0148f94f483f3e1489"
+
+SRC_URI[sha256sum] = "9c2ea1e62d871267b78307fe511c0838ba0da28698c5732d54e2790bf3ba9899"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-profile \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-difflib \
+"
+
+BBCLASSEXTEND = "native nativesdk"