aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-humanfriendly_9.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-humanfriendly_9.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-humanfriendly_9.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-humanfriendly_9.1.bb b/meta-python/recipes-devtools/python/python3-humanfriendly_9.1.bb
new file mode 100644
index 0000000000..fb6a7e3b6d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-humanfriendly_9.1.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Human friendly output for text interfaces using Python"
+HOMEPAGE = "https://humanfriendly.readthedocs.io/"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=764e737b117a38d773609885e8d04f0b"
+
+PYPI_PACKAGE = "humanfriendly"
+
+SRC_URI[sha256sum] = "066562956639ab21ff2676d1fda0b5987e985c534fc76700a19bd54bcb81121d"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN}_class-target += " \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-fcntl \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-math \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-stringold \
+"
+
+BBCLASSEXTEND = "native"