aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-google-auth_2.6.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-google-auth_2.6.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-google-auth_2.6.3.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-google-auth_2.6.3.bb b/meta-python/recipes-devtools/python/python3-google-auth_2.6.3.bb
new file mode 100644
index 0000000000..ee5311f4fb
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-google-auth_2.6.3.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Google Authentication Library"
+HOMEPAGE = "https://github.com/googleapis/google-auth-library-python"
+AUTHOR = "Google Cloud Platform"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "d65bb0e3701eaaa64fd2aa85e1325580524b0bddc6dc5db3ab89c481b6a20141"
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-asyncio \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-numbers \
+"
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-aiohttp \
+ ${PYTHON_PN}-cachetools \
+ ${PYTHON_PN}-pyasn1-modules \
+ ${PYTHON_PN}-rsa \
+ ${PYTHON_PN}-six \
+"