aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-google-api-python-client_2.15.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-google-api-python-client_2.15.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-google-api-python-client_2.15.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-google-api-python-client_2.15.0.bb b/meta-python/recipes-devtools/python/python3-google-api-python-client_2.15.0.bb
new file mode 100644
index 0000000000..6172cd28f5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-google-api-python-client_2.15.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "The Google API Client for Python is a client library for accessing the Plus, \
+Moderator, and many other Google APIs."
+HOMEPAGE = "https://github.com/googleapis/google-api-python-client"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+SRC_URI[sha256sum] = "8375489232823f44c601196a960505e03ec58c95ddb6415c6b1d1d76b468f8ba"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-httplib2 \
+ ${PYTHON_PN}-uritemplate \
+ ${PYTHON_PN}-google-api-core \
+"