aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb b/meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb
new file mode 100644
index 0000000000..8e967f9259
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb
@@ -0,0 +1,36 @@
+SUMMARY = "ECDSA cryptographic signature library (pure python)"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=66ffc5e30f76cbb5358fe54b645e5a1d"
+
+PYPI_PACKAGE = "ecdsa"
+SRC_URI[sha256sum] = "60eaad1199659900dd0af521ed462b793bbdf867432b3948e87416ae4caf6bf8"
+
+inherit pypi setuptools3 python3native ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ python3-hypothesis \
+ python3-pytest \
+ python3-unittest-automake-output \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/src/ecdsa/* ${D}${PTEST_PATH}/tests/
+}
+
+RDEPENDS:${PN} += " \
+ python3-gmpy2 \
+ python3-json \
+ python3-six \
+"
+
+do_install:append() {
+ rm ${D}${PYTHON_SITEPACKAGES_DIR}/ecdsa/test_*.py
+}
+
+BBCLASSEXTEND = "native nativesdk"