aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ecdsa_0.16.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ecdsa_0.16.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ecdsa_0.16.1.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ecdsa_0.16.1.bb b/meta-python/recipes-devtools/python/python3-ecdsa_0.16.1.bb
new file mode 100644
index 0000000000..819d41e86e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ecdsa_0.16.1.bb
@@ -0,0 +1,13 @@
+SUMMARY = "ECDSA cryptographic signature library (pure python)"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=66ffc5e30f76cbb5358fe54b645e5a1d"
+
+DEPENDS += "python3-pip python3-pbr"
+
+PYPI_PACKAGE = "ecdsa"
+SRC_URI[sha256sum] = "cfc046a2ddd425adbd1a78b3c46f0d1325c657811c0f45ecc3a0a6236c1e50ff"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "python3-six python3-gmpy2 python3-pbr"