aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-coverage_6.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-coverage_6.5.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-coverage_6.5.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-coverage_6.5.0.bb b/meta-python/recipes-devtools/python/python3-coverage_6.5.0.bb
new file mode 100644
index 0000000000..dfa374d87a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-coverage_6.5.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Code coverage measurement for Python"
+HOMEPAGE = "https://coverage.readthedocs.io"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2ee41112a44fe7014dce33e26468ba93"
+
+SRC_URI[sha256sum] = "f642e90754ee3e06b0e7e51bce3379590e76b7f76b708e1a71ff043f87025c84"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-sqlite3 \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-xml \
+ ${PYTHON_PN}-crypt \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-io \
+"