aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-autobahn_22.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-autobahn_22.6.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-autobahn_22.6.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-autobahn_22.6.1.bb b/meta-python/recipes-devtools/python/python3-autobahn_22.6.1.bb
new file mode 100644
index 0000000000..71da18f812
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-autobahn_22.6.1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "WebSocket client & server library, WAMP real-time framework"
+HOMEPAGE = "http://crossbar.io/autobahn"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=97c0bda20ad1d845c6369c0e47a1cd98"
+
+SRC_URI[sha256sum] = "fb63e946d5c2dd0df680851e84e65624a494ce87c999f2a4944e4f2d81bf4498"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-twisted \
+ ${PYTHON_PN}-zopeinterface \
+ ${PYTHON_PN}-py-ubjson \
+ ${PYTHON_PN}-cbor2 \
+ ${PYTHON_PN}-u-msgpack-python \
+ ${PYTHON_PN}-lz4 \
+ ${PYTHON_PN}-snappy \
+ ${PYTHON_PN}-pyopenssl \
+ ${PYTHON_PN}-txaio \
+ ${PYTHON_PN}-six \
+"
+
+BBCLASSEXTEND = "native nativesdk"