aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-astor/f820f3ff7ad8818475b6e107e63aa9a54252d2a9.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-astor/f820f3ff7ad8818475b6e107e63aa9a54252d2a9.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-astor/f820f3ff7ad8818475b6e107e63aa9a54252d2a9.patch22
1 files changed, 19 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-astor/f820f3ff7ad8818475b6e107e63aa9a54252d2a9.patch b/meta-python/recipes-devtools/python/python3-astor/f820f3ff7ad8818475b6e107e63aa9a54252d2a9.patch
index 823699339e..6d71be9927 100644
--- a/meta-python/recipes-devtools/python/python3-astor/f820f3ff7ad8818475b6e107e63aa9a54252d2a9.patch
+++ b/meta-python/recipes-devtools/python/python3-astor/f820f3ff7ad8818475b6e107e63aa9a54252d2a9.patch
@@ -3,14 +3,27 @@ From: Jonathan Ringer <jonringer117@gmail.com>
Date: Thu, 17 Oct 2019 16:54:16 -0700
Subject: [PATCH] Fix packaging for setuptools>=41.4
+Upstream-Status: Pending
+
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
---
+ MANIFEST.in | 1 +
astor/VERSION | 1 +
astor/__init__.py | 5 ++++-
setup.cfg | 3 ++-
setup.py | 16 +---------------
- 4 files changed, 8 insertions(+), 17 deletions(-)
+ 5 files changed, 9 insertions(+), 17 deletions(-)
create mode 100644 astor/VERSION
+diff --git a/MANIFEST.in b/MANIFEST.in
+index b12a6fe..81e72d5 100644
+--- a/MANIFEST.in
++++ b/MANIFEST.in
+@@ -1,3 +1,4 @@
+ include README.rst AUTHORS LICENSE CHANGES
+ include setuputils.py
++include astor/VERSION
+ recursive-include tests *.py
diff --git a/astor/VERSION b/astor/VERSION
new file mode 100644
index 0000000..a3df0a6
@@ -22,7 +35,7 @@ diff --git a/astor/__init__.py b/astor/__init__.py
index 3b02983..8dfcdb1 100644
--- a/astor/__init__.py
+++ b/astor/__init__.py
-@@ -9,6 +9,7 @@
+@@ -9,6 +9,7 @@ Copyright 2013 (c) Berker Peksag
"""
@@ -30,7 +43,7 @@ index 3b02983..8dfcdb1 100644
import warnings
from .code_gen import SourceGenerator, to_source # NOQA
-@@ -19,7 +20,9 @@
+@@ -19,7 +20,9 @@ from .op_util import get_op_symbol, get_op_precedence # NOQA
from .op_util import symbol_data # NOQA
from .tree_walk import TreeWalk # NOQA
@@ -85,3 +98,6 @@ index 4a111b5..6068493 100644
-setup(**config['options'])
+setup()
+--
+2.21.0
+