aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-aiofiles_23.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-aiofiles_23.2.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-aiofiles_23.2.1.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aiofiles_23.2.1.bb b/meta-python/recipes-devtools/python/python3-aiofiles_23.2.1.bb
new file mode 100644
index 0000000000..73dc17423e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-aiofiles_23.2.1.bb
@@ -0,0 +1,15 @@
+SUMMARY = "File support for asyncio"
+DESCRIPTION = "Asynchronous local file IO library for asyncio and Python"
+HOMEPAGE = "https://github.com/aio-libs/aiohttp"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
+
+SRC_URI[sha256sum] = "84ec2218d8419404abcb9f0c02df3f34c6e0a68ed41072acfb1cef5cbc29051a"
+
+PYPI_PACKAGE = "aiofiles"
+
+inherit pypi python_hatchling
+
+RDEPENDS:${PN} = "\
+ python3-asyncio \
+"