aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-twisted_13.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-twisted_13.2.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-twisted_13.2.0.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-twisted_13.2.0.bb b/meta-python/recipes-devtools/python/python-twisted_13.2.0.bb
index 89301691e1..2b433f718e 100644
--- a/meta-python/recipes-devtools/python/python-twisted_13.2.0.bb
+++ b/meta-python/recipes-devtools/python/python-twisted_13.2.0.bb
@@ -38,7 +38,13 @@ PACKAGES += "\
${PN}-core \
"
+PACKAGES =+ "\
+ ${PN}-src \
+ ${PN}-bin \
+"
+
RDEPENDS_${PN} = "\
+ ${PN}-bin \
${PN}-conch \
${PN}-lore \
${PN}-mail \
@@ -233,3 +239,9 @@ ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/.debug \
${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/.debug \
"
+RDEPENDS_{PN}-src = "${PN}"
+FILES_${PN}-src = " \
+ ${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py \
+ ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*.py \
+ ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/*.py \
+ "