aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pyserial_2.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pyserial_2.7.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-pyserial_2.7.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyserial_2.7.bb b/meta-python/recipes-devtools/python/python-pyserial_2.7.bb
new file mode 100644
index 0000000000..276db34bf2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyserial_2.7.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Serial Port Support for Python"
+SECTION = "devel/python"
+LICENSE = "PSF"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c557c64905dac5b725980b9505bf8d7b"
+SRCNAME = "pyserial"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+# FIXME might stop packaging serialwin32 and serialjava files
+
+RDEPENDS_${PN} = "\
+ python-fcntl \
+ python-io \
+ python-stringold \
+"
+
+SRC_URI[md5sum] = "794506184df83ef2290de0d18803dd11"
+SRC_URI[sha256sum] = "3542ec0838793e61d6224e27ff05e8ce4ba5a5c5cc4ec5c6a3e8d49247985477"