aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-protobuf_3.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-protobuf_3.4.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-protobuf_3.4.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-protobuf_3.4.0.bb b/meta-python/recipes-devtools/python/python-protobuf_3.4.0.bb
new file mode 100644
index 0000000000..cde62b74a4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-protobuf_3.4.0.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Protocol Buffers"
+HOMEPAGE = "https://developers.google.com/protocol-buffers/"
+SECTION = "devel/python"
+
+RDEPENDS_${PN} = "python-six"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
+
+inherit pypi setuptools
+
+SRC_URI[md5sum] = "bfc0c61c156a995e909521697e755780"
+SRC_URI[sha256sum] = "ef02609ef445987976a3a26bff77119c518e0915c96661c3a3b17856d0ef6374"
+
+# For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools)
+BBCLASSEXTEND = "native"