aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pbr_3.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pbr_3.0.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-pbr_3.0.1.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pbr_3.0.1.bb b/meta-python/recipes-devtools/python/python-pbr_3.0.1.bb
new file mode 100644
index 0000000000..b84836ae13
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pbr_3.0.1.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Python Build Reasonableness: PBR is a library that injects some useful and sensible default behaviors into your setuptools run"
+HOMEPAGE = "https://pypi.python.org/pypi/pbr"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
+
+SRC_URI[md5sum] = "c537dbb9756e319be25772b1fe1c05fa"
+SRC_URI[sha256sum] = "d7e8917458094002b9a2e0030ba60ba4c834c456071f2d0c1ccb5265992ada91"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN}_class-target += " \
+ python-pip \
+ "
+
+BBCLASSEXTEND = "native"