aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-lxml_3.4.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-lxml_3.4.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-lxml_3.4.4.bb34
1 files changed, 1 insertions, 33 deletions
diff --git a/meta-python/recipes-devtools/python/python-lxml_3.4.4.bb b/meta-python/recipes-devtools/python/python-lxml_3.4.4.bb
index 4fab4f3d5c..81ccb12d87 100644
--- a/meta-python/recipes-devtools/python/python-lxml_3.4.4.bb
+++ b/meta-python/recipes-devtools/python/python-lxml_3.4.4.bb
@@ -1,34 +1,2 @@
-SUMMARY = "Python XML bindings for libxml2 and libxslt"
-DESCRIPTION = "Powerful and Pythonic XML processing library combining \
-libxml2/libxslt with the ElementTree API."
-HOMEPAGE = "http://codespeak.net/lxml"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=f9f1dc24f720c143c2240df41fe5073b"
-SRCNAME = "lxml"
-
-DEPENDS = "libxml2 libxslt"
-
-SRC_URI = "http://pypi.python.org/packages/source/l/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
-
-SRC_URI[md5sum] = "a9a65972afc173ec7a39c585f4eea69c"
-SRC_URI[sha256sum] = "b3d362bac471172747cda3513238f115cbd6c5f8b8e6319bf6a97a7892724099"
-
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
inherit setuptools
-
-DISTUTILS_BUILD_ARGS += " \
- --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
- --with-xml2-config='${STAGING_BINDIR_CROSS}/pkg-config libxml2' \
-"
-
-DISTUTILS_INSTALL_ARGS += " \
- --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
- --with-xml2-config='${STAGING_BINDIR_CROSS}/pkg-config libxml2' \
-"
-
-BBCLASSEXTEND = "native nativesdk"
-
-RDEPENDS_${PN} += "libxml2 libxslt python-compression"
-RDEPENDS_${PN}_class-native = "libxml2-native libxslt-native"
-
+require python-lxml.inc