aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-cryptography_2.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-cryptography_2.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography_2.3.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-cryptography_2.3.bb b/meta-python/recipes-devtools/python/python-cryptography_2.3.bb
new file mode 100644
index 0000000000..9c2f88418d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cryptography_2.3.bb
@@ -0,0 +1,22 @@
+inherit pypi setuptools
+require python-cryptography.inc
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+DEPENDS += " \
+ ${PYTHON_PN}-enum34 \
+"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-enum34 \
+ ${PYTHON_PN}-ipaddress \
+"
+
+RDEPENDS_${PN}_class-target += " \
+ ${PYTHON_PN}-enum34 \
+ ${PYTHON_PN}-ipaddress \
+ ${PYTHON_PN}-contextlib \
+ ${PYTHON_PN}-subprocess \
+"