aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-automat.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-automat.inc')
-rw-r--r--meta-python/recipes-devtools/python/python-automat.inc8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-automat.inc b/meta-python/recipes-devtools/python/python-automat.inc
index 1ac5d3b323..43b9ce9e3c 100644
--- a/meta-python/recipes-devtools/python/python-automat.inc
+++ b/meta-python/recipes-devtools/python/python-automat.inc
@@ -3,6 +3,8 @@ HOMEPAGE = "https://github.com/glyph/Automat"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=4ad213bcca81688e94593e5f60c87477"
+FILESEXTRAPATHS_prepend := "${THISDIR}/python-automat:"
+
SRC_URI[md5sum] = "ad7bba58d262d8956d732330cb5ef53d"
SRC_URI[sha256sum] = "3c1fd04ecf08ac87b4dd3feae409542e9bf7827257097b2b6ed5692f69d6f6a8"
@@ -10,6 +12,12 @@ PYPI_PACKAGE = "Automat"
inherit pypi
+SRC_URI_append = " \
+ file://0001-setup.py-remove-the-dependency-on-m2r.patch \
+"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
RDEPENDS_${PN} += "\
${PYTHON_PN}-attrs \
${PYTHON_PN}-six \