aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-connectivity
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-connectivity')
-rw-r--r--meta-python/recipes-connectivity/python-gsocketpool/python3-gsocketpool_0.1.6.bb7
-rw-r--r--meta-python/recipes-connectivity/python-h2/python3-h2_4.1.0.bb (renamed from meta-python/recipes-connectivity/python-h2/python3-h2_4.0.0.bb)5
-rw-r--r--meta-python/recipes-connectivity/python-hpack/python3-hpack_4.0.0.bb2
-rw-r--r--meta-python/recipes-connectivity/python-priority/python3-priority_2.0.0.bb (renamed from meta-python/recipes-connectivity/python-priority/python3-priority_1.3.0.bb)3
-rw-r--r--meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman_0.2.0.bb2
-rw-r--r--meta-python/recipes-connectivity/python-pyro4/python3-pyro4_4.80.bb16
-rw-r--r--meta-python/recipes-connectivity/python-pyro4/python3-pyro4_4.82.bb15
-rw-r--r--meta-python/recipes-connectivity/python-thrift/python3-thrift_0.13.0.bb18
-rw-r--r--meta-python/recipes-connectivity/python-thrift/python3-thrift_0.20.0.bb20
-rw-r--r--meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb8
-rw-r--r--meta-python/recipes-connectivity/python3-pytun/python3-pytun_2.4.1.bb (renamed from meta-python/recipes-connectivity/python3-pytun/python3-pytun_2.3.0.bb)3
-rw-r--r--meta-python/recipes-connectivity/telepathy/telepathy-python3-0.15.19/remove_duplicate_install.patch10
-rw-r--r--meta-python/recipes-connectivity/telepathy/telepathy-python3-0.15.19/telepathy-python_fix_for_automake_1.12.patch2
-rw-r--r--meta-python/recipes-connectivity/telepathy/telepathy-python3_0.15.19.bb21
14 files changed, 69 insertions, 63 deletions
diff --git a/meta-python/recipes-connectivity/python-gsocketpool/python3-gsocketpool_0.1.6.bb b/meta-python/recipes-connectivity/python-gsocketpool/python3-gsocketpool_0.1.6.bb
index d3e7d48dab..60ac18155f 100644
--- a/meta-python/recipes-connectivity/python-gsocketpool/python3-gsocketpool_0.1.6.bb
+++ b/meta-python/recipes-connectivity/python-gsocketpool/python3-gsocketpool_0.1.6.bb
@@ -3,8 +3,11 @@ DESCRIPTION = "creates a pool of connections that can be used with gevent"
HOMEPAGE = "https://github.com/studio-ousia/gsocketpool"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=4ba825394aec026b5f94edca44426859"
-DEPENDS += "${PYTHON_PN}-gevent"
-RDEPENDS_${PN} += "${PYTHON_PN}-gevent"
+
+RDEPENDS:${PN} += " \
+ python3-gevent \
+ python3-logging \
+"
SRC_URI[md5sum] = "49f5f292ef1b60944ae92ca426a5e550"
SRC_URI[sha256sum] = "f2e2749aceadce6b27ca52e2b0a64af99797746a8681e1a2963f72007c14cb14"
diff --git a/meta-python/recipes-connectivity/python-h2/python3-h2_4.0.0.bb b/meta-python/recipes-connectivity/python-h2/python3-h2_4.1.0.bb
index ff1d20a89e..6b3ce25371 100644
--- a/meta-python/recipes-connectivity/python-h2/python3-h2_4.0.0.bb
+++ b/meta-python/recipes-connectivity/python-h2/python3-h2_4.1.0.bb
@@ -4,9 +4,8 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=aa3b9b4395563dd427be5f022ec321c1"
-SRC_URI[md5sum] = "d086f6a9746a5f4eeb63bb3d0a482e1f"
-SRC_URI[sha256sum] = "bb7ac7099dd67a857ed52c815a6192b6b1f5ba6b516237fc24a085341340593d"
+SRC_URI[sha256sum] = "a83aca08fbe7aacb79fec788c9c0bac936343560ed9ec18b82a13a12c28d2abb"
inherit pypi setuptools3
-RDEPENDS_${PN} += "${PYTHON_PN}-hpack ${PYTHON_PN}-hyperframe"
+RDEPENDS:${PN} += "python3-hpack python3-hyperframe"
diff --git a/meta-python/recipes-connectivity/python-hpack/python3-hpack_4.0.0.bb b/meta-python/recipes-connectivity/python-hpack/python3-hpack_4.0.0.bb
index afba98e4b3..0297cb8c27 100644
--- a/meta-python/recipes-connectivity/python-hpack/python3-hpack_4.0.0.bb
+++ b/meta-python/recipes-connectivity/python-hpack/python3-hpack_4.0.0.bb
@@ -8,3 +8,5 @@ SRC_URI[md5sum] = "27e01514ef06dc9fa0798d3dcb7de47c"
SRC_URI[sha256sum] = "fc41de0c63e687ebffde81187a948221294896f6bdc0ae2312708df339430095"
inherit pypi setuptools3
+
+RDEPENDS:${PN} += "python3-logging"
diff --git a/meta-python/recipes-connectivity/python-priority/python3-priority_1.3.0.bb b/meta-python/recipes-connectivity/python-priority/python3-priority_2.0.0.bb
index 5d84571f9f..93b694c8b8 100644
--- a/meta-python/recipes-connectivity/python-priority/python3-priority_1.3.0.bb
+++ b/meta-python/recipes-connectivity/python-priority/python3-priority_2.0.0.bb
@@ -4,7 +4,6 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae57d8a09fc8b6b164d7357339619045"
-SRC_URI[md5sum] = "4f1ff52f7fa448e9d9cb46337ae86d1e"
-SRC_URI[sha256sum] = "6bc1961a6d7fcacbfc337769f1a382c8e746566aaa365e78047abe9f66b2ffbe"
+SRC_URI[sha256sum] = "c965d54f1b8d0d0b19479db3924c7c36cf672dbf2aec92d43fbdaf4492ba18c0"
inherit pypi setuptools3
diff --git a/meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman_0.2.0.bb b/meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman_0.2.0.bb
index b80c167bb5..359a2918cf 100644
--- a/meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman_0.2.0.bb
+++ b/meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman_0.2.0.bb
@@ -9,4 +9,4 @@ SRC_URI[sha256sum] = "d3a63a039c82b08a1171b003eafa62c6f128aa4eaa1ce7a55a9401b48f
inherit pypi setuptools3
-RDEPENDS_${PN} = "connman python3-dbus python3-pprint"
+RDEPENDS:${PN} = "connman python3-dbus python3-pprint python3-future"
diff --git a/meta-python/recipes-connectivity/python-pyro4/python3-pyro4_4.80.bb b/meta-python/recipes-connectivity/python-pyro4/python3-pyro4_4.80.bb
deleted file mode 100644
index dfea673687..0000000000
--- a/meta-python/recipes-connectivity/python-pyro4/python3-pyro4_4.80.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-SUMMARY = "Python Remote Objects"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=cd13dafd4eeb0802bb6efea6b4a4bdbc"
-
-SRC_URI[md5sum] = "e31fc077e06de9fc0bb061e357401954"
-SRC_URI[sha256sum] = "46847ca703de3f483fbd0b2d22622f36eff03e6ef7ec7704d4ecaa3964cb2220"
-
-PYPI_PACKAGE = "Pyro4"
-
-inherit pypi setuptools3
-
-RDEPENDS_${PN} += " \
- ${PYTHON_PN}-logging \
- ${PYTHON_PN}-serpent \
- ${PYTHON_PN}-threading \
- "
diff --git a/meta-python/recipes-connectivity/python-pyro4/python3-pyro4_4.82.bb b/meta-python/recipes-connectivity/python-pyro4/python3-pyro4_4.82.bb
new file mode 100644
index 0000000000..c49e67c919
--- /dev/null
+++ b/meta-python/recipes-connectivity/python-pyro4/python3-pyro4_4.82.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Python Remote Objects"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=cd13dafd4eeb0802bb6efea6b4a4bdbc"
+
+SRC_URI[sha256sum] = "511f5b0804e92dd77dc33adf9c947787e3f9e9c5a96b12162f0557a7c4ce21fb"
+
+PYPI_PACKAGE = "Pyro4"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-logging \
+ python3-serpent \
+ python3-threading \
+ "
diff --git a/meta-python/recipes-connectivity/python-thrift/python3-thrift_0.13.0.bb b/meta-python/recipes-connectivity/python-thrift/python3-thrift_0.13.0.bb
deleted file mode 100644
index 80f1a50178..0000000000
--- a/meta-python/recipes-connectivity/python-thrift/python3-thrift_0.13.0.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-SUMMARY = "Python bindings for the Apache Thrift RPC system"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://PKG-INFO;md5=e95cd2f17c70d3180a2b361332319fe0"
-
-SRC_URI[md5sum] = "c3bc8d9a910d2c9ce26f2ad1f7c96762"
-SRC_URI[sha256sum] = "9af1c86bf73433afc6010ed376a6c6aca2b54099cc0d61895f640870a9ae7d89"
-
-inherit pypi setuptools3
-
-# Use different filename to prevent conflicts with thrift itself
-PYPI_SRC_URI_append = ";downloadfilename=${BP}.${PYPI_PACKAGE_EXT}"
-
-RDEPENDS_${PN} += "\
- ${PYTHON_PN}-logging \
- ${PYTHON_PN}-six \
- ${PYTHON_PN}-stringold \
- ${PYTHON_PN}-threading \
-"
diff --git a/meta-python/recipes-connectivity/python-thrift/python3-thrift_0.20.0.bb b/meta-python/recipes-connectivity/python-thrift/python3-thrift_0.20.0.bb
new file mode 100644
index 0000000000..6a0a66aef5
--- /dev/null
+++ b/meta-python/recipes-connectivity/python-thrift/python3-thrift_0.20.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Python bindings for the Apache Thrift RPC system"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515"
+
+SRC_URI[sha256sum] = "4dd662eadf6b8aebe8a41729527bd69adf6ceaa2a8681cbef64d1273b3e8feba"
+
+inherit pypi setuptools3
+
+# Use different filename to prevent conflicts with thrift itself
+PYPI_SRC_URI:append = ";downloadfilename=${BP}.${PYPI_PACKAGE_EXT}"
+
+RDEPENDS:${PN} += "\
+ python3-logging \
+ python3-scons \
+ python3-six \
+ python3-stringold \
+ python3-threading \
+"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb b/meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb
index e235682cf4..ab39606bdb 100644
--- a/meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb
+++ b/meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb
@@ -6,10 +6,14 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=76699830db7fa9e897f6a1ad05f98ec8"
DEPENDS = "python3-twisted python3-six python3-vcversioner python3-six-native python3-vcversioner-native"
-SRC_URI = "git://github.com/MostAwesomeDude/txWS.git"
+RDEPENDS:${PN} += " \
+ python3-six \
+ python3-twisted \
+"
+
+SRC_URI = "git://github.com/MostAwesomeDude/txWS.git;branch=master;protocol=https"
SRCREV= "88cf6d9b9b685ffa1720644bd53c742afb10a414"
S = "${WORKDIR}/git"
inherit setuptools3
-
diff --git a/meta-python/recipes-connectivity/python3-pytun/python3-pytun_2.3.0.bb b/meta-python/recipes-connectivity/python3-pytun/python3-pytun_2.4.1.bb
index bc11d705f4..08ec2cf670 100644
--- a/meta-python/recipes-connectivity/python3-pytun/python3-pytun_2.3.0.bb
+++ b/meta-python/recipes-connectivity/python3-pytun/python3-pytun_2.4.1.bb
@@ -2,8 +2,7 @@ SUMMARY = "Python TUN/TAP tunnel module"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=13f7629e8e4989b66b4a913ab05a91de"
-SRC_URI[md5sum] = "adcaeea56d0ed06814487cdbde32d198"
-SRC_URI[sha256sum] = "5ead86b3391acef239535ebcabeb04d2cdc6b40ab14580d28c6da193c2d1fe53"
+SRC_URI[sha256sum] = "20b53ea7a09dfe173c00ec0a00eea508b05e959f5dc4b4bb698aa52252192f8f"
PYPI_PACKAGE = "python-pytun"
diff --git a/meta-python/recipes-connectivity/telepathy/telepathy-python3-0.15.19/remove_duplicate_install.patch b/meta-python/recipes-connectivity/telepathy/telepathy-python3-0.15.19/remove_duplicate_install.patch
index df95a4c138..04d2da8ef2 100644
--- a/meta-python/recipes-connectivity/telepathy/telepathy-python3-0.15.19/remove_duplicate_install.patch
+++ b/meta-python/recipes-connectivity/telepathy/telepathy-python3-0.15.19/remove_duplicate_install.patch
@@ -2,14 +2,14 @@ commit f6c67662145de889055a86a6b3b12c70a45fc8d5
Author: Dongxiao Xu <dongxiao.xu@intel.com>
Date: Wed Sep 7 16:02:20 2011 +0800
- Avoid duplicated installation of errors.py
+Avoid duplicated installation of errors.py
- newer version of autotools don't seem to like listing files to install
- twice. Remove one errors.py from the installation list.
+newer version of autotools don't seem to like listing files to install
+twice. Remove one errors.py from the installation list.
- Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
+Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
- Upstream-Status: Inappropirate [upstream inactive]
+Upstream-Status: Inappropriate [upstream inactive]
diff --git a/src/Makefile.am b/src/Makefile.am
index 5c27dfe..7536e43 100644
diff --git a/meta-python/recipes-connectivity/telepathy/telepathy-python3-0.15.19/telepathy-python_fix_for_automake_1.12.patch b/meta-python/recipes-connectivity/telepathy/telepathy-python3-0.15.19/telepathy-python_fix_for_automake_1.12.patch
index f613fdce4d..0498f3ddd0 100644
--- a/meta-python/recipes-connectivity/telepathy/telepathy-python3-0.15.19/telepathy-python_fix_for_automake_1.12.patch
+++ b/meta-python/recipes-connectivity/telepathy/telepathy-python3-0.15.19/telepathy-python_fix_for_automake_1.12.patch
@@ -9,7 +9,7 @@ of warning-errors.
| make[1]: Leaving directory `/srv/home/nitin/builds2/build0/tmp/work/i586-poky-linux/telepathy-python-0.15.19-r4/telepathy-python-0.15.19/src'
| make: *** [all-recursive] Error 1
-Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
+Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
2012/07/10
Index: telepathy-python-0.15.19/src/Makefile.am
===================================================================
diff --git a/meta-python/recipes-connectivity/telepathy/telepathy-python3_0.15.19.bb b/meta-python/recipes-connectivity/telepathy/telepathy-python3_0.15.19.bb
index d92e6577af..23c2165047 100644
--- a/meta-python/recipes-connectivity/telepathy/telepathy-python3_0.15.19.bb
+++ b/meta-python/recipes-connectivity/telepathy/telepathy-python3_0.15.19.bb
@@ -1,6 +1,6 @@
SUMMARY = "Telepathy IM framework - Python package"
HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
-LICENSE = "LGPLv2.1+"
+LICENSE = "LGPL-2.1-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1 \
file://src/utils.py;beginline=1;endline=17;md5=9a07d1a9791a7429a14e7b25c6c86822"
@@ -11,7 +11,6 @@ SRC_URI = "http://telepathy.freedesktop.org/releases/telepathy-python/telepathy-
file://remove_duplicate_install.patch \
file://telepathy-python_fix_for_automake_1.12.patch"
-PR = "r6"
S = "${WORKDIR}/telepathy-python-${PV}"
@@ -20,15 +19,15 @@ inherit autotools python3native
SRC_URI[md5sum] = "f7ca25ab3c88874015b7e9728f7f3017"
SRC_URI[sha256sum] = "244c0e1bf4bbd78ae298ea659fe10bf3a73738db550156767cc2477aedf72376"
-FILES_${PN} += "\
- ${libdir}/python*/site-packages/telepathy/*.py \
- ${libdir}/python*/site-packages/telepathy/*/*.py \
+FILES:${PN} += "\
+ ${PYTHON_SITEPACKAGES_DIR}/telepathy/*.py \
+ ${PYTHON_SITEPACKAGES_DIR}/telepathy/*/*.py \
"
-do_install_append () {
- rm -fr ${D}${libdir}/python*/site-packages/telepathy/__pycache__
- rm -fr ${D}${libdir}/python*/site-packages/telepathy/__pycache__
- rm -fr ${D}${libdir}/python*/site-packages/telepathy/*/__pycache__
- rm -fr ${D}${libdir}/python*/site-packages/telepathy/*/__pycache__
+do_install:append () {
+ rm -fr ${D}${PYTHON_SITEPACKAGES_DIR}/telepathy/__pycache__
+ rm -fr ${D}${PYTHON_SITEPACKAGES_DIR}/telepathy/__pycache__
+ rm -fr ${D}${PYTHON_SITEPACKAGES_DIR}/telepathy/*/__pycache__
+ rm -fr ${D}${PYTHON_SITEPACKAGES_DIR}/telepathy/*/__pycache__
}
-RDEPENDS_${PN} += "python3-dbus"
+RDEPENDS:${PN} += "python3-dbus"